Re: problems with new shapes

At 17.08.2008 01:54, Rob Savoye wrote:
[...]  Today I was trying to
add a few new symbols to my sheet only to discover it doesn't seem to work anymore. To create a new shape, I draw save as a .dia, then export as a .shape. Then I go in and add the "New" shape file. When I do this, the png is zero bytes, and the shape file gets truncated to zero, so nothing gets imported. I tried this on 4 different GNU/Linux distros (all running 96.1), plus grabbed svn, and tried a few different versions to find nothing seems to work anymore. I always wind up with truncated .png and .shape files. I'd love to find out I'm doing something wrong so I can finish this latest project.

I have looked at the sources and can't find anything obviously wrong. Are you sure the effect occurs at load time (and not already when exporting the shapes)? If yes you can try to add your new shape to the respective sheet file without Dia's GUI, i.e. using a text editor.

Maybe Dia stumbles over the concrete shape/png cobination you are using, if so it would make sense to make them available for testing.

-------- Hans "at" Breuer "dot" Org -----------
Tell me what you need, and I'll tell you how to
get along without it.                -- Dilbert

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]