Re: dia+osx? help!

Gotcha.  So in bash right now when I type dia, I only get "command not found".  Do I need to enable X11 fowarding and use ssh -X to create a remote session to run dia?  I'm going off what I found here:

Thank you!

On 8/24/07, Ben Abbott <bpabbott mac com> wrote:

botkiller promo wrote:
> I'm confused ... I've installed dia via darwinports on OS X 10.4.9 - but
> how
> do I run it?  I am new to this, I apologize - but I can't find anything on
> how I run dia after all this.  In terminal, if I type dia I get
> (dia:16671)
> gtk-warning **: cannot open display: , and I'm kicked back.  What am I
> doing
> wrong?  Do I need to run dia in X11?  Did my install not complete or
> something?  I know that dia is installed, but this is quite annoying...
> thanks.
> -brian

Brian, as Lars mentioned, you'll need to run X11. If you don't already have
in installed, it is optionally installed from your OSX install disks.
Following the link below for more detail.

Once you have X11 installed (it will show up in your Utilities folder) you
may run dia by (1) running x11, (2) starting an xterm window, (3) typing
"dia" from the xterm window. As an alternative to (2)/(3) you can add the
command "dia" to you x11 application menu and start dia from there.

View this message in context:
Sent from the Gnome - Dia mailing list archive at

Dia-list mailing list
Dia-list gnome org
FAQ at
Main page at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]