Re: Cairo image format

On Tuesday 08 August 2006 00.08, Hans Breuer wrote:
Maybe the way to go would have been to follow the advice from the console
dump. Or maybe you already did ...

Yes, I did so afterwards, and I've followed that thread, and have seen that 
they have fixed it now.

The problem was that I thought that I had missed something when I compiled 
cairo, as I couldn't believe that the image format was not supported, and 
just assumed that I had missed an option somewhere.

However, I had some other related problems(with gtk+) that I solved, and got 
it working perfectly well. So, I have a working dia on the solaris computer - 
it works perfectly - that is, as long as I log in from a Linux box. :-)

Probably BGR (and it seems to be fixed with upcoming cairo 1.2.2), see

Yes, that seems to be the problem.

If your later attempt (disabling the cairo *plug-in*) did not work, please
update again. Or even downgrade cause gtk+-2.6 did not have the cairo
dependency and Dia should still run with that version.

The funny thing was that I disabled the plugin, and solved a few other 
problems, and got it working perfectly on Saturday when I had logged on from 
my Linux computer at home.
So, I was very amazed to find that the error message was back again, when I 
tried to run it from a Solaris computer yesterday. :-)

But I won't bother compiling the 2.6 versions of gtk+/glib/pango, and so on. 
I'll just wait for cairo 1.2.2, that should be released soon.

Thanks anyway.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]