Re: GNOME 2.20 Python version

On Mon, 2007-03-12 at 18:02 +0000, Gustavo J. A. M. Carneiro wrote:
> I'd like to suggest updating jhbuild to install Python 2.5 instead of
> 2.4 for GNOME 2.20, because:
>   * I don't think Python 2.4 will continue to be maintained;
>   * Distributions that will receive GNOME 2.20 will most likely make
> python 2.5 the default (ubuntu already does for GNOME 2.18);
>   * We could really use the testing of GNOME on Python 2.5, especially
> on 64-bit systems.

This makes sense. I suggest you go ahead with this when the 2.20 modules
are created. The release team might want to specify this as an official
external dependency, but if it's not listed as one now then you can
probably just go ahead.

I hope that people try to #ifdef around the relevant code so that it
builds with both.

Murray Cumming
murrayc murrayc com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]