Re: Putting the 'Mono debate' back on the rails

Mike Kestner wrote:

My Gtk#-lite 2.16 binding would be allowed to break API in 2.18 as long

as I make it parallel-installable, thereby breaking all existing
Gtk#-lite applications unless packagers provide Bindings release 2.16
with their 2.18 desktop

  parallel-instabllable is the worst idea of software development.
One ended with forked version of software and only create more
maintaineable nightmare. We are all tremendous hackers/engineers,
so stick to some good engineering principles :)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]