GStreamer 0.8 versus 0.10 (was: Re: requesting official list of modules and versions for GNOME 2.14)

Hi Thomas,

> So, for comparison, I tried doing something on 0.8 that you keep
> claiming works fine: DVD playback.

> I used my 3GHz hyperthreaded home machine - my laptop has a crappy DVD
> drive that can't even play most dvd's I have.

I've tried the same thing on my dual celeron (433Mhz) box at home,
picking 3 DVD's from the pile on my desk. Using 0.8.11 plus Tim's
alsasink fixes, then 0.8.12 with a 0.8.7 ffmpeg installation with a
bunch of backported fixes and an updated ffmpeg core from 10/01/2006.

All the packages come from my local breezy repository on cf.o -- except
Totem, which i'm using the upstream version of.

DVD 1: Spaced, Season II (R2)

+ choosing audio works
- subtitles don't
! during the BBC copyright screen, the visualiser (goom) is shown, after
it moves to the menu, it's fine.
+ the menus work
! A/V desync happens at scene-change, seeking fixes it
! seeking skips the audio, then the video "fast-forwards" for 5-10sec
and catches up.
! episode transition doesn't work, it goes back to the menu.

DVD 2: Shameless, Season I (R4)
- subtitles are on by default and you can't turn them off
- during the ABC logo, I get audio-hiss (alsasink, 2 channel, ISA Sound
Blaster 64-AWE))
- the scrollbar doesn't move during the copyright warning, but
automatically moves to the ABC logo at ~20sec.
+ the menus work
+ seeking works

DVD 3: Dark City (R4)
+ choosing audio works
+ the scrollbar keeps the correct time during the copyright warning
! the menus sort-of-work, you can click the buttons, but the screen goes
black and doesn't display the submenu.
+++++ PERFECT A/V sync, even when my cat decides to walk across the
keyboard triggering multiple fast-forward/rewinds.
+++++ managed to watch the whole movie, in totem, in fullscreen (using
xvimagesink) without an issue.

Now, if you compare those to 0.10. (I know, DVD playback doesn't work)
-- totem coughs up a warning message that says:

"No Reason"

On all three :)

As a developer, I could probably be forgiven for wondering:

* is this because I can't be arsed rebuilding libdvdcss for my
0.10-based box?
* is this because i'm missing the 0.10 plugin for DVD playback (if such
a thing existed as released source)?

However, as a user, "No Reason" isn't really a good thing, is it?

Maybe, (as has been alluded to many times on p.g.o and elsewhere) things
have come to a point where:

* "media player of choice(tm)" needs an error message that correctly
states the problem (Totem cannot play your DVD, DVD Playback has not
been completed yet, please click here (point to GStreamer homepage) for
more information)


* "media player of choice(tm)" needs a button, which detects
distribution-of-choice and goes off looking for a suitable set of
"unofficial" plugins that are unsupported, but actually work.

Otherwise, a distribution like Ubuntu Dapper Drake, with it's proposed
lengthy support period -- might have a bit of a problem attracting home
users, who consider playing their movies/porn/illicitly-gained-audio
more important than the quality of the "backend" they are using.

Don't get me wrong, GStreamer 0.10 from CVS looks, feels and acts a lot
more funkey than 0.8 did -- it even plays some weird formats that many
non-developers have never even heard of -- but it *does* appear to have
less functionality, for 99% of non-technicial users.



> DVD 1: "Aardvark'd"
> + choosing audio language works
> - subtitles are enabled unconditionally.  There is no way to turn them
> off from the menu (it says "no subtitle selection available").
> - subtitle shadows bleed over the rest of the image (see
>; I switched
> to ximagesink to make the screenshot)
> - there's no way to go back to the main menu (nothing happens when
> choosing options from the "Go" menu)
> - seeking messes up the synchronization; after a seek, the audio is
> easily a second off from video (using osssink or alsasink)
> - during playback, audio repeatedly stutters in very short bursts;
> probably related to the A/V desync
> - I did one run where I did not seek at all, just let it play from the
> start - A/V was also not in sync already after 90 seconds
> - sometimes seeking doesn't do anything at all, period.  I drag and
> release the slider, and nothing happens.  No seek, no time update,
> nothing.
> - while playing it uses 70% CPU and above (using xvimagesink).  Overall
> playback is jerky, definately not as smooth as other players.
> - during some runs, the initial "boondoggle" logo section at the start
> of the disc starts slowing down to a crawl at the end, then takes half a
> minute to complete and go to the menu
> + clicking on items in the menu works in the sense that it moves on to
> the movie ...
> - ... but it didn't actually do what the option said; for example I
> chose a different audio track from the menu, and I had the main one.  I
> could still choose a different audio track from the menu though.
> - during playback, I regularly get criticals; assertions about caps
> changes that failed and gst_tag_list assertions
> - I've had a few "Internal GStreamer error" messages pop up during
> playback; surprisingly, the DVD continued playing just fine :)
> - two times, after a seek, it started consuming all my memory and sent
> my machine in a swap storm, finally killing totem.
> All in all, it's not even watchable if you just pop in the disc and tell
> it to play, without doing anything special.
> I tried some other DVD's as well:
> - "Much ado about nothing": plays the MGM intro (thougn not
> deinterlaced), then at the end freezes, waits five seconds, pops up an
> Internal GStreamer error dialog, and then renders the first screen of
> the menu.  Nothing in the menu works, play does not work, and there's no
> way to start the movie.
> - "Chasing Amy": strangely enough, this presented me with the file
> chooser dialog when picking "Play Disc".  Mplayer plays it fine as a
> dvd.  Probably not a GStreamer bug, but something lower down the stack.
> - "meeting people is easy": annoyingly, this dvd has a 43 second
> "warning" section as the first section.  Amusingly, the position
> indicator was jumping back and forth all the time while playing.  At the
> end of the section, again the last frew frames slowed to a crawl
> completely until they faded out to black, and then I got the menu.  No
> error dialog, so good.  I could pick "play" from the menu, and playing
> worked.  First seek made the movie stutter.  Movie is not deinterlaced.
> Not in sync either.
> - "Pixies": does not even start at all.    Clicking play again throws a
> bunch of criticals about invalid casts, then segfaults.  Mplayer plays
> it.  This is a DVD without menus, as far as I can tell, but with several
> tracks.
> - "The office series 1": starts, plays the 20 second author organisation
> clip.  Second clip is the age guideline clip, which is scrambled until
> halfway through.  Third clip is the BBC one.  After this, a GStreamer
> dialog pops up, together with an initial frame from the menu.  After
> that, nothing works anymore.
> These six DVD's were taken from the top of my DVD pile; they all play
> fine on my Playstation (my main DVD watching machine).  Overall, my
> experience seems to match the experiences from other people out there
> from a quick google on "totem gstreamer DVD"  So final score is two
> halves out of six - not enough to make it a bullet point pro gstreamer
> 0.8, I think.
> As has been said before in related threads - the DVD support was added
> late in the GNOME 2.12 cycle and with clear disclaimers.  Since then,
> very little work has been done on it in the 0.8 branch.  I don't expect
> much more work to be done there - you're currently the only person doing
> any work on the 0.8 branch, and you said that you didn't have a DVD
> drive to test with anymore.  So I don't think it can be claimed that DVD
> in totem with GStreamer 0.8 works well.  There's a big difference
> between making it work on a developer's machine, and making it work
> everywhere.
> Don't get me wrong here - I think that you did excellent work in getting
> as far as you did within the limits of 0.8.  But everyone who has hacked
> on DVD support in 0.8 has admitted that there are serious problems in
> the 0.8 design when it comes to supporting DVD's.
> What are other people's experiences with DVD playback in
> totem/gstreamer-0.8 ?
> Thomas
> Dave/Dina : future TV today ! -
> <-*- thomas (dot) apestaart (dot) org -*->
> Now I find myself redeemed
> 'cos no one's seen the bad in me
> or been where I've been
> <-*- thomas (at) apestaart (dot) org -*->
> URGent, best radio on the net - 24/7 ! -
> _______________________________________________
> desktop-devel-list mailing list
> desktop-devel-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]