New Modules in GNOME 2.2: gstreamer

If people are worried that gstreamer is not yet ready to be part of
GNOME then one solution would just be to accept that you must stabilize
and support a possibly immature API while continuing development in an
unstable branch. APIs need to be used to mature, but APIs need to be
stable to be used - there must be a workable compromise between the two.

This would be a bit like the old libxml situation. Daniel supported an
old API that he really disliked (and didn't enjoy doing it) but that
didn't stop the API from improving in libxml2.

I know that GNOME 2 APIs are supposed to be so good that they will be
the same for ever, but that might be an unreasonable demand for new
stuff. It's obviously not true of some of the libgnomeui stuff.

Murray Cumming
murray usa net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]