Re: complete restore homedir hangs

Hmm, comments below.

On Thu, Oct 17, 2019, at 20:46, jonikelee via deja-dup-list wrote:
If this isn't a bug in deja-dup itself, I'd guess it was because the
restore was writing over all sorts of vital things in the homedir of
the logged in user, and ultimately caused something to lock up as a

Obviously, the hanging is not great. I haven't had recent reports of similar hangs. Your guess of a bad 
overwrite is plausible?

If you have the time to test, does the VM hang if you don't restore to the same locations, but rather to a 
new restore folder? That would avoid the overwrite problem.

I also tried using duplicity itself to do the restore.  This
had entirely different problems.  Apparently because
deja-dup sets the base dir for the backups to /, duplicity will restore
to /home/me/home/me instead of /home/me, when told to restore /home/me.
If duplicity is instead told to restore at /, it refuses - which seems
entirely appropriate for security sake.  Why does deja-dup set the base
dir (called Localdir in the manifest?) to / instead of the home dir it
was assigned to backup?

Because it makes it easier to add directories that are outside the home dir to the backup. When restoring, 
Deja Dup does some smarts to move things to the right place (like if your backup only has one home dir, but 
it's a different name than your current one, we figure that out, etc).

What is the most successful way to use deja-dup/duplicity to completely
restore a homedir?  Starting from a system with a default-config'ed
homedir for that user?  Or, no homedir?  Or, empty homedir?  Logged in
as that user, or root?  Su'ed to that user from some other or root?

If you're using deja-dup, the assumption is that you're a user sitting in a session. So you'd have a valid 
running desktop / home folder. And what you were trying to do sounds like it should have worked...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]