Re: Building with GTK < 3.22

Hi Michael!
I tried commenting and changing the dependency, but I still ended up getting an error:
$ make
ninja -C builddir
ninja: Entering directory `builddir'
[0/1] Regenerating build files
The Meson build system
Version: 0.40.1
Source dir: /media/paul/str/source/deja-dup
Build dir: /media/paul/str/source/deja-dup/builddir
Build type: native build
Project name: deja-dup
Native c compiler: cc (gcc 5.4.0)
Native vala compiler: valac (valac 0.30.1)
Build machine cpu family: x86_64
Build machine cpu: x86_64
Program appstream-util found: YES (/usr/bin/appstream-util)
Program dbus-run-session found: YES (/usr/bin/dbus-run-session)
Program desktop-file-validate found: YES (/usr/bin/desktop-file-validate)
Program glib-compile-schemas found: YES (/usr/bin/glib-compile-schemas)
Program msgfmt found: YES (/usr/bin/msgfmt)
Configuring org.gnome.DejaDup.service using configuration
Configuring org.gnome.DejaDup.Monitor.desktop using configuration
Configuring using configuration
Configuring org.gnome.DejaDup.policy using configuration
Found pkg-config: /usr/bin/pkg-config (0.29.1)
Native dependency glib-2.0 found: YES 2.48.2
WARNING: GLib compiled dependencies do not work reliably with
the current version of GLib. See the following upstream issue:
Message: You may need to recompile your gsettings schemas or regenerate
         your icon cache after installation.
Configuring duplicity.plugin using configuration
Program ./validate-linguas found: YES (/media/paul/str/source/deja-dup/deja-dup/help/./validate-linguas)
Program ./validate-linguas found: YES (/media/paul/str/source/deja-dup/po/./validate-linguas)
Build targets in project: 21
[1/87] Compiling Vala source ../libdeja/Backend.vala ../libdeja/Backend...ursiveMove.vala ../libdeja/RecursiveOp.vala ../libdeja/ToolPlugin.vala.
FAILED: libdeja/deja@sha/Backend.c libdeja/deja@sha/BackendAuto.c libdeja/deja@sha/BackendDrive.c libdeja/deja@sha/BackendFile.c libdeja/deja@sha/BackendGCS.c libdeja/deja@sha/BackendGOA.c libdeja/deja@sha/BackendLocal.c libdeja/deja@sha/BackendOpenstack.c libdeja/deja@sha/BackendRackspace.c libdeja/deja@sha/BackendRemote.c libdeja/deja@sha/BackendS3.c libdeja/deja@sha/BackendU1.c libdeja/deja@sha/CommonUtils.c libdeja/deja@sha/DirHandling.c libdeja/deja@sha/FilteredSettings.c libdeja/deja@sha/Network.c libdeja/deja@sha/Operation.c libdeja/deja@sha/OperationBackup.c libdeja/deja@sha/OperationFiles.c libdeja/deja@sha/OperationRestore.c libdeja/deja@sha/OperationStatus.c libdeja/deja@sha/OperationVerify.c libdeja/deja@sha/RecursiveDelete.c libdeja/deja@sha/RecursiveMove.c libdeja/deja@sha/RecursiveOp.c libdeja/deja@sha/ToolPlugin.c libdeja/deja.h libdeja/deja.vapi
valac '--debug' '-d' 'libdeja/deja@sha' '-C' '--library=deja' '-H' 'libdeja/deja.h' '--vapi' '../deja.vapi' '--pkg' 'gio-2.0' '--pkg' 'gio-unix-2.0' '--pkg' 'goa-1.0' '--pkg' 'goa-backend-1.0' '--pkg' 'packagekit-glib2' '--pkg' 'libpeas-1.0' '--pkg' 'libsecret-1' '--pkg=config' '--pkg=posix' '--target-glib=2.46' '--vapidir' '/media/paul/str/source/deja-dup/vapi' '--define=HAS_PACKAGEKIT' '--pkg=secret' '--pkg=uriutils' ../libdeja/Backend.vala ../libdeja/BackendAuto.vala ../libdeja/BackendDrive.vala ../libdeja/BackendFile.vala ../libdeja/BackendGCS.vala ../libdeja/BackendGOA.vala ../libdeja/BackendLocal.vala ../libdeja/BackendOpenstack.vala ../libdeja/BackendRackspace.vala ../libdeja/BackendRemote.vala ../libdeja/BackendS3.vala ../libdeja/BackendU1.vala ../libdeja/CommonUtils.vala ../libdeja/DirHandling.vala ../libdeja/FilteredSettings.vala ../libdeja/Network.vala ../libdeja/Operation.vala ../libdeja/OperationBackup.vala ../libdeja/OperationFiles.vala ../libdeja/OperationRestore.vala ../libdeja/OperationStatus.vala ../libdeja/OperationVerify.vala ../libdeja/RecursiveDelete.vala ../libdeja/RecursiveMove.vala ../libdeja/RecursiveOp.vala ../libdeja/ToolPlugin.vala
error: Package `goa-1.0' not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)
[2/87] Static linking library deja-dup/nautilus/libdirhandling.a
ninja: build stopped: subcommand failed.
Makefile:20: recipe for target 'all' failed
make: *** [all] Error 1

Is there supposed to be a goa-1.0.vapi in the ./vapi directory? It's not included upstream.

On Sun, Feb 11, 2018 at 12:39 PM, Michael Terry <mike mterry name> wrote:

GTK 3.22 is I think only needed for a tiny call to Gtk.show_uri_on_window. If you comment that out in deja-dup/widgets/WidgetUtils.vala, you can probably downgrade the requirement to 3.18. Let me know if that works, and we can add a conditional compile-time check for GTK 3.22 to use that line or the older Gtk.show_uri.


On Sun, Feb 11, 2018, at 13:35, Paul Clarke wrote:
I've been using Deja Dup for a while, and was thinking about helping out with some of the outstanding bugs. It works great on my system, which is linux mint with gtk 3.18.9.

When I tried to build it, though, meson told me it requires gtk >= 3.22, which my os doesn't have a package for, and would probably be a pain to compile from source. Is gtk 3.22 really required for development, or is there an easy way to turn off that dependency? Thanks,
deja-dup-list mailing list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]