Re: Building with GTK < 3.22


GTK 3.22 is I think only needed for a tiny call to Gtk.show_uri_on_window. If you comment that out in deja-dup/widgets/WidgetUtils.vala, you can probably downgrade the requirement to 3.18. Let me know if that works, and we can add a conditional compile-time check for GTK 3.22 to use that line or the older Gtk.show_uri.


On Sun, Feb 11, 2018, at 13:35, Paul Clarke wrote:
I've been using Deja Dup for a while, and was thinking about helping out with some of the outstanding bugs. It works great on my system, which is linux mint with gtk 3.18.9.

When I tried to build it, though, meson told me it requires gtk >= 3.22, which my os doesn't have a package for, and would probably be a pain to compile from source. Is gtk 3.22 really required for development, or is there an easy way to turn off that dependency? Thanks,
deja-dup-list mailing list
deja-dup-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]