Re: Error starting up Beagle 0.2.0 for first time

Joe Shaw wrote:


On Mon, 2006-01-23 at 18:51 -0700, Jared Smith wrote:
After many trial and errors I was able to get beagle 0.2.0 installed from source. When I went to start for the first time I got this. I have googled the error without any luck. Hoping someone here might have some input. This is the error I see:

sjaredj shine:~/Apps/Beagle$ beagled

** (/usr/local/lib/beagle/BeagleDaemon.exe:28312): WARNING **: Missing method chmod in assembly /usr/local/lib/beagle/Util.dll, type Mono.Unix.Native.Syscall

What version of mono do you have installed?

It looks like beagle was built against a certain version of mono, but is
run against a different version.  Can you delete your old version of
Util.dll and then rebuild and reinstall beagle?



Thanks for the reply. I have mono installed, but to give you some more background I tried to get this all working with my distribution packages (kubuntu breezy) but kept getting some "object" error (can't totally remember it). I decided at that time to try compiling things myself from the latest beagle build. It took a while to satisfy the prerequistes and get ./configure to run without errors. In doing that all I had only remove the kubuntu package named mono and not all the other utils and development mono packages. I went ahead and did as you said and removed all packages refering to mono with exception of two, libmono0 and mono-common (I got other mono errors until I added those two back in). I then reinstalled mono from its install binary that I downloaded from I also recompiled gmime-2.1.19 since the package version from kubuntu would not satisfy the prerequisite version. Lastly I recompiled beagle 0.2.0. Everything compiled and installed without error. When I ran beagled I got this different error:

sjaredj shine:/opt/beagle-0.2.0$ beagled --fg --debug
Debug: Starting Beagle Daemon (version 0.2.0)
Debug: Command Line: /usr/local/lib/beagle/BeagleDaemon.exe --fg --debug
Warn: Extended attributes are not supported on this filesystem. Performance will suffer as a result.
Error: Unhandled exception thrown.  Exiting immediately.
Error: System.DllNotFoundException: glibsharpglue-2
in (wrapper managed-to-native) GLib.Marshaller:glibsharp_strlen (intptr)
in <0x00020> GLib.Marshaller:Utf8PtrToString (IntPtr ptr)
in <0x000ad> GLib.Argv:GetArgs (Int32 argc)
in <0x00106> Gtk.Application:do_init (System.String progname, System.String[] args, Boolean check) in <0x0000f> Gtk.Application:InitCheck (System.String progname, System.String[] args)
in <0x00628> Beagle.Daemon.BeagleDaemon:DoMain (System.String[] args)
in <0x00014> Beagle.Daemon.BeagleDaemon:Main (System.String[] args)

Not sure what to do with this one. I tried compiling and installing gtk-sharp2 2.4 to see if that would help and it gave this same error. Any more suggestions?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]