Re: [PATCH] Don't force gtkmozembed in the Facebook module

On Tue, Mar 18, 2008 at 8:18 AM, Chris Rivera <chrismrivera gmail com> wrote:
On Fri, Mar 14, 2008 at 11:25 PM, John Stowers <john stowers gmail com> wrote:
Hi Cris, thanks for the explanation, comments inline
Im not sure I like this change. The hardcoding of the built in web-browser in facebook is intentional - this is because if you make any facebook API calls with the (as yet unauthenticated token) it revokes that tokens validity, which means when the user finishes logging in, Conduits login token token request is denied.

This is similar to what happens with rememberthemilk.  I was playing around with an RTM conduit module and ran into this same problem.

There is a RTM conduit module?? :-)

I've been playing around with one.  I'm not quite sure how to map the tasks to conduit data types.  RTM is set of lists that contains tasks.  Each task can have several notes about the task.  Each task also has scheduling information.  Suggestions?

This sounds like how works. In that case I just create a page (called Conduit by default, configurable, if it doesn't exist), and put the notes on that page. Its not perfect, but is not optimal, the web interface doesnt even record the modification times for notes when they are edited from the web.

I needed this option to work because gtkmozembed is segfaulting on opensuse11.0 alpha 2 with conduit trunk.   It's segfaulting in during gtkmozembed.MozEmbed().  Running python and doing this manually works fine though.  I don't have a handle on what's going on yet. 

Have you checked the conduit/conduit shell script (i.e. not conduit/conduit.real python code) to check that it finds the run-mozilla script?

see the line

FF_PATH=`ls -d /usr/lib/firefox* | tail -n 1`

is that the correct path on opensuse for ff libs?

The TestWebBrowser dataprovider is useful for testing the built in browser

Interestingly firefox3 gecko1.9 (tested on Ubuntu hardy) finally fixed this problem, no more yucky wrapper script needed!

Let me know if this helps

The conduit shell script is working correctly.  If I run and just run I get the same crash.  If I run without it works fine.

Hmm, thats a weird combination of things working/not working. The only time I have seen something similar to what you describe is when I had ff3 and ff2 both installed and it would find the wrong script, or something like that, I dont remember exactly.

Im sorry I cant be of more help tracking this down. If conduit works on your distribution without the wrapper script then the packagers are welcome to remove the wrapper, like I am going to recommend is done in ubuntu 8.04 conduit package -it seems to be no longer needed with ff3/gecko 1.9



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]