[vala] (73 commits) Non-fast-forward update to branch mjog/jsc_object_add_property



The branch 'mjog/jsc_object_add_property' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  54eda1a... WIP: vapi/javascriptcoregtk-4.0.vapi: Fix JSC.Class.add_pro

Commits added to the branch:

  31afbf4... girwriter: Don't use instance-parameter inside callback (2) (*)
  43e98d9... javascriptcoregtk-4.0,webkit2gtk-web-extension-4.0: Fix som (*)
  321fd98... codegen: Fix default value of get_ccode_destroy_notify_pos( (*)
  e2edf1f... codegen: Always use CCodeConstant for NULL (*)
  ba1231c... codegen: Don't override valid target/destroy of previous la (*)
  df6abd2... pixman-1: Fix some bindings errors (*)
  cafa826... zlib: Fix some bindings errors (*)
  6cf363b... x11: Fix some bindings errors (*)
  eeb6729... libusb-1.0: Fix some bindings errors (*)
  959594d... libusb: Fix some bindings errors (*)
  50cbf91... codegen: Don't call *_instance_init() in compact class chai (*)
  b5f4bf0... tests: Extend "this chainup in compact class" test (*)
  f5203f7... Release 0.52.1 (*)
  c9c7c78... codegen: Don't free temp-var for element-access to array wi (*)
  5ac8840... codegen: Don't free temp-var for element-access to array wi (*)
  1cb798d... tests: Extend "GArray" tests to increase coverage (*)
  3c69ceb... codegen: Don't free unowned heap allocated struct (*)
  b9728ba... glib-2.0: Add simple_generics attribute to GenericArray.fin (*)
  23ccd78... Release 0.52.2 (*)
  5aa1911... Bump version suffix to 0.54 (*)
  4a08b52... vala: Add Profile.LIBC as synonym for POSIX and accept "lib (*)
  3877c50... vala: Improve semantic check of simple type structs (*)
  a7012f0... vala: Refactor UnresolvedSymbol/Type constructors (*)
  cbc11c2... parser: Minor semantic checks to improve error messages (*)
  20fcf9c... parser: Allow empty member-initializer and accept trailing  (*)
  909423c... vapi: Remove webkit-1.0 bindings (*)
  60461f3... vapi: Remove gedit-2.20 bindings (*)
  46986e4... codegen: Use ArrayType.length_type in type specific wrapper (*)
  636d63a... codegen: Use ssize_t for length variables in common array h (*)
  9023a8d... parser: Include INTERR token in source_reference of parsed  (*)
  11e6f71... vala: length-type of arrays must not be nullable (*)
  eb7dc13... vapi: Update GIR-based bindings (*)
  4f2ef8f... Support explicit nullable var-type declarations (*)
  0202055... codegen: Make sure to include <sys/types.h> for ssize_t (PO (*)
  38d61fb... vala: Properly check GLib.Object naming convention for prop (*)
  edc0b53... codegen: Apply gconstpointer to gpointer cast to GenericTyp (*)
  7641f50... codegen: Fix access to captured generics in async method of (*)
  c2a9ded... codegen: Add get_generic_type_expression() and handle Gener (*)
  b8be96c... Make TypeParameter a TypeSymbol to resolve functions with a (*)
  58675b6... codegen: Unify handling of GenericType arguments/parameters (*)
  b165d68... codegen: Use if-clause for is_in_destructor() condition to  (*)
  6f30d21... codegen: More use of get_variable_cexpression() (*)
  376df8b... tests: Extend "finally block execution" test to increase co (*)
  f1d8635... tests: Add "generics reference transfer" test to increase c (*)
  d7123cf... tests: Add more "DBus" tests to increase coverage (*)
  472765b... codegen: Emit external creation methods in bindings (*)
  d0615e6... glib-2.0: Wrap TimeZone.identifier() constuctor for proper  (*)
  145bfaf... vala: length-type of arrays must not be nullable (2) (*)
  f6be4cb... codegen: Add missing "_return" label and "_inner_error*_" d (*)
  bace269... vala: Report a warning for unhandled errors in destructors (*)
  5052dd9... codegen: Don't use G_GNUC_INTERNAL on implicit type specifi (*)
  ae15049... tests: Add "delete" test to increase coverage (*)
  7e2bbeb... tests: Add "generic array" test to increase coverage (*)
  2d848e2... tests: Extend "array field intializer" test to increase cov (*)
  2345446... tests: Add "properties in structs" test to increase coverag (*)
  9bd62d5... Sync NEWS from 0.52 (*)
  1448119... codegen: GArray, GByteArray and GPtrArray are reference cou (*)
  f904c7e... vala: Add foreach statement support for GLib.GenericArray (*)
  bdd0ecd... tests: Add "ThreadPool" test to increase coverage (*)
  d26ff2c... tests: Refactor "fields" test to increase coverage (*)
  90cf1ea... codegen: Drop unreachable code handling (Un)LockStatements (*)
  e232223... codegen: Replace wrongly hard coded usage of G_OBJECT_GET_C (*)
  9cbd53b... codegen: Add CCodeBaseModule.get_this_class_cexpression() a (*)
  1ad53f2... codgen: Generalize CCodeBaseModule.get_this_interface_cexpr (*)
  86fecf1... codegen: Always use G_TYPE_INSTANCE_GET_CLASS/INTERFACE for (*)
  8b8340a... codegen: More use of get_this_{class|interface}_cexpression (*)
  318df95... build: Add "test-asan" make target for convenience (*)
  793e86c... vapi: Update GIR-based bindings (*)
  1a4e31c... gstreamer-rtp-1.0: Fix typo in re-parenting for RTCP symbol (*)
  65301ac... gstreamer-rtp-1.0: Fix some bindings errors (*)
  76343ba... gstreamer-rtp-1.0: Move some static functions to matching p (*)
  463c632... Add support for variadic delegates (*)
  48501b6... javascriptcoregtk-4.0: Fix JSC.Class.add_property() binding

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]