[gtk+] Created tag 3.21.2



The unsigned tag '3.21.2' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Thu May 26 16:42:36 2016 -0400

    3.21.2

Changes since the last tag '3.21.1':

Alban Browaeys (1):
      widget: fix GtkLabelAccessible NULL links.

Anders Jonsson (1):
      Updated Swedish translation

Aurimas Černius (1):
      Updated Lithuanian translation

Balázs Meskó (1):
      Updated Hungarian translation

Bastian Ilsø (1):
      gtktextview: document how to get line space

Baurzhan Muftakhidinov (1):
      Updated Kazakh translation     (cherry picked from commit d1585a7a60d760a0c98934f970c4403023a399c3)

Benjamin Otte (8):
      widget: Remove useless comment
      cssimagebuiltin: Remove unused variables
      cssimagebuiltin: Remove icons that don't draw anything anymore
      cssimage: Make it possible to shrink builtin check/optionmarks
      scrolledwindow: Remove child before destroying self
      scrolledwindow: destroy children in destroy()
      widget: No longer postpone style-updated on unrealized widgets
      window: Unfreeze window on unmap

Carlos Garnacho (6):
      gdkevents: Free motion events discarded by motion compression
      searchenginetracker: Quote fts match so it's seen as a single phrase
      x11: Rely on passive keyboard grabs with XI2 for DnD
      wayland: Avoid spurious crossing events from master touch device
      x11/dnd: Ignore grab broken events from other devices than our DnD device.
      popover: set priv->window before setting doing add_popover() on it

Carlos Soriano (2):
      gtknotebook: avoid tab dnd from content
      testnotebookdnd: add one GtkListBox as tab content

Christian Hergert (3):
      iconhelper: check if surface was invalidated
      Revert "iconhelper: check if surface was invalidated"
      wayland: use g_signal_handler_disconnect()

Chun-wei Fan (5):
      gdk/win32/gdkmonitor-win32.c: Fix build on non-GCC
      Visual Studio builds: Clean up projects a bit
      gdk/Makefile.am: Dist gdkmonitorprivate.h
      Visual Studio builds: Refine "installation" process
      GTK: Fix build for pre-C99 compilers

Cédric Valmary (2):
      Updated Occitan translation
      Updated Occitan translation

Daniel Mustieles (3):
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation

Debarshi Ray (3):
      scrolledwindow: Fix typo in get_preferred_height calculation
      scrolledwindow: Remove redundant use of MAX
      scrolledwindow: Better size requisition for GTK_SCROLL_NATURAL children

Dušan Kazik (1):
      Updated Slovak translation

Emmanuele Bassi (4):
      docs: Update examples of matching key bindings
      gl: Add a realize() fallback
      gdk: Provide safe fallback for creating GL contexts
      Silence a compiler warning

Florian Müllner (1):
      stack: Only map children when necessary

Friedrich Herbst (1):
      Updated German translation

GNOME Translation Robot (1):
      Updated Scottish Gaelic translation

Georges Basile Stavracas Neto (1):
      placesview: update guiding list of protocols

Ignacio Casal Quinteiro (2):
      gtkselectionprivate: minor style fix
      gtktextview: fix < public > comment

Javier Jardón (1):
      Use upstream gettext

Khaled Hosny (2):
      Update Arabic translation
      Typo

Kjartan Maraas (2):
      Updated Norwegian bokmål translation.
      Updated Norwegian bokmål translation.

Lapo Calamandrei (14):
      Adwaita: add a background to cellrendertext
      Adwaita: refactor levelbar styling.
      Adwaita: more flexible headerbar_fill mixin
      Adwaita: tidy treeview style properties...
      Adwaita: relocate a selector
      Adwaita: cosmetic change
      Adwaita: darken treeview exapanders
      Adwaita: hide separator on button.font and button.file
      Adwaita: bold size label on font button
      Adwaita: brighter pushed button background
      Adwaita: fix scale theming
      color scale: Really sync style classes with GtkScale
      Adwaita: shave 1px from the switch
      Adwaita: add vertical margins to switches on a headerbar

Matt Watson (1):
      stack: always update window position at transition start

Matthew Waters (1):
      gdk/wayland: use the multi-thread safe wayland API

Matthias Clasen (123):
      Add GdkMonitor
      display: Add new monitor apis
      Add a fallback for unconverted backends
      screen: Implement old monitor apis generically
      integrate docs
      wayland: Port to new monitor api
      broadway: Port to new monitor api
      x11: Drop Xinerama
      x11: Port to new monitor api
      x11: Bring back fullscreen-on-all-monitors support
      inspector: Port to new monitor api
      menu: Add new monitor api
      gtk: Port to new monitor api
      combobox: Stop using screen width/height
      label: Stop using screen width/height
      treeview: Stop using screen width/height
      window: Stop using screen width/height
      settings: Stop comparing screen numbers
      window: Stop using gdk_screen_get_n_monitors
      box gadget: allow reversing alignments
      check button: Reverse alignments in RTL
      expander: Reverse alignments in RTL
      box gadget: Redo expand flag handling
      settings: Cache xsettings
      Add a forgotten deprecation
      gdk: Add a private getter for GdkDevice::input-mode
      Use the new getter
      Trivial whitespace fix
      Add a few settings getters
      dnd: Use a getter for the drag threshold
      css: Use a getter for the enable-animations setting
      Use a better hash for arcs
      Use a variable consistently
      popover: Use getter for gtk-enable-animations
      Use getter for gtk-enable-animations
      scrolled window: Use getter for gtk-enable-animations
      stack: Use getter for gtk-enable-animations
      switch: Use getter for gtk-enable-animations
      treeview: Use getter for gtk-enable-animations
      settings: Add setters for font family and size
      css: Use setters for font size and family
      wayland: Make gdk_display_get_name work
      wayland: Tag the event source with the acutal display name
      Fix the build
      wayland: drop a useless list
      x11: drop a useless list
      Drop unused macros
      Small docs improvement
      Avoid copying an event
      gesture: Don't leak stashed events
      dnd: Make sure to free a stashed event
      Fix gtk_paned_set_position to set position_set consistently
      GdkMonitor: Fix refresh-rate property
      defaultvalue test: Skip GdkMonitor::geometry
      css: Stop drawing double borders for builtins
      Use g_set_object in one more place
      trivial formatting fixes
      wayland: Don't emit direction-changed unless it did
      wayland: Small improvements to update_direction
      settings: Ensure derived fields are initialized
      settings: Fix xsettings handling
      css names are always set
      Set the proper state on the css node
      When creating a widget path, use the widget type
      Revert "When creating a widget path, use the widget type"
      box: Only emit ::child-notify when necessary
      css node: Stop extraneous change notification
      settings: Avoid a crash
      Generalize the previous commit
      scale: Fix mark positioning at the left/top edge
      Update color name css style test
      Fix a typo
      Fix indentation mishap
      Use a cheaper way to store debug flags
      Use a cheaper way to store settings per display
      tooltip: Ensure our quark is not 0
      Ensure we initialize a quark first
      widget: Store accessible in GtkWidgetPrivate
      settings: Fix font names *again*
      Don't use qdata for getting the default css style
      Stop storing has-tooltip in qdata
      Don't emit ::query-tooltip by name
      Avoid emitting ::style-set by name
      builder tool: Canonicalize property names
      Clean up builder parser data after parsing
      Simplify our templates
      gtk-demo: Don't duplicate text in markup example
      gtk3-demo: Add a close button to the markup window
      tooltip: Add a missing *
      gtk-demo: Fix revealer demo
      Make gdk_event_get_pointer_emulated public
      Document new api
      Forgotten rename
      Fix scale length
      x11: Trap possible X error
      places sidebar: Avoid markup confusion in tooltips
      DND: Avoid a use-after-free
      Docs: Clarify life cycle issue
      wayland: Avoid unitialized memory reads
      scale: Avoid a crash
      gtk3-demo: Add context-menu cursor
      gtk-demo: Update no-drop cursor image
      Update cursor docs
      Revert "scrolledwindow: Better size requisition for GTK_SCROLL_NATURAL children"
      scale: Bring back marks-related style classes
      wayland: Survive lack of settings
      icon theme: Add a warning
      scale: Use more succinct names for style classes
      color scale: Sync style classes with GtkScale
      scale css node test: Adapt to changes
      treeview: Fix a rubberbanding-related crash
      infobar: Update documentation
      Remove an unused variable
      Trivial typo fix
      Improve CSS docs a bit
      Add a deprecation note
      Fix a duplicate word in the docs
      Update migration guide a bit
      Move release notes to online docs
      Mention CSS font property in the release notes
      Teach gtk-builder-tool to leave GtkDialog::border-width alone
      Updates
      3.21.2

Matthieu Gautier (1):
      revealer: emit notify::child-revealed when animation stops

Olivier Fourdan (8):
      wayland: fix up/down mix up in discrete events
      gdkevent: make _gdk_event_get_pointer_emulated() private
      gtkmenu: ignore emulated scroll events
      gtkmenu: ignore left/right scroll events
      display: Add vfunc for get_monitor_at_window
      wayland: Add API to retrieve the Wayland output
      wayland: Add get_monitor_at_window to Wayland backend
      wayland: Make gdk_wayland_window_get_wl_output() private

Ondrej Holy (1):
      Improve external drives detection

Rafael Fontenelle (1):
      Updated Brazilian Portuguese translation     (cherry picked from commit 
207b793316a90faff00d5ea6fbe483d5a184d066)

Ray Strode (1):
      widget: add missing detail to ::query-tooltip emission

Rico Tzschichholz (1):
      broadway: Fix include rules in gdkbroadwaymonitor.h

Tiago Santos (3):
      Updated Portuguese translation
      Updated Portuguese translation
      Updated Portuguese translation

Timm Bäder (28):
      shadowsvalue: Don't draw invisible box shadows
      roundedbox: Initialize the hashtable key before using it
      widget: Remove useless NULL check
      label: Don't set out parameters twice
      label: minimum/natural size parameters are not nullable
      label: don't use set_text in gtk_label_new
      switch: Create less pango layouts
      switch: Remove .slider from slider gadget
      gtkrender: Remove superfluous cairo_save/restore calls
      cssgadget: Remove unused function
      label: Also initialize text
      infobar: Fix typo
      gdk: Fix parameter name mismatch
      tooltip: Include gtkwidgetprivate.h
      dialogs: remove 2px border width again
      widget: Add Since annotation to gtk_widget_queue_allocate
      scale: Remove double nullable annotation
      widget-factory: Let one of the scales draw a value
      Scale: Set the correct value alignment
      toolbar: Limit item position to number of contained elements
      colorbutton: Stop using state-changed
      listbox: Don't compare int to uint
      query-settings: Don't compare int to uint
      Remove useless casts from gdk_event_triggers_context_menu calls
      stack: Remove some code duplication
      stack: Don't underallocate the last_child
      query-settings: Indicate deprecated settings
      gdkwindow: Use GList less

Руслан Ижбулатов (7):
      GtkTreeView: change child repositioning to preserve locality
      win32: Port to new monitor api
      W32: reword the error about required cairo version
      W32: support cairo library in non-standard locations
      GtkPlacesView: check for network:// URI support before using it
      Use default VFS, not a local one (it has no network)
      GtkFileChooser: don't override already opened folder


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]