[gtk+] docs: correct various spelling and grammar errors
- From: Will Thompson <wjt src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk+] docs: correct various spelling and grammar errors
- Date: Mon, 4 Mar 2013 22:50:18 +0000 (UTC)
commit 507bf6e5cf9c88b8eed91a4449e4c4558c8c5f84
Author: Will Thompson <will willthompson co uk>
Date: Wed Feb 29 17:19:55 2012 +0000
docs: correct various spelling and grammar errors
I noticed a few cases of "wether", and while fixing them noticed a few
"its" which should be "it's". It all went downhill from there.
gtk/gactionobserver.c | 2 +-
gtk/gtkaccelmap.c | 2 +-
gtk/gtkcellarea.c | 8 ++++----
gtk/gtkcellareacontext.c | 6 +++---
gtk/gtkcellrenderer.c | 2 +-
gtk/gtkcellview.c | 8 ++++----
gtk/gtkicontheme.c | 2 +-
gtk/gtkspinbutton.c | 2 +-
gtk/gtktestutils.c | 6 +++---
gtk/gtktoolitem.c | 2 +-
gtk/gtkwidget.c | 6 +++---
gtk/gtkwindow.c | 2 +-
12 files changed, 24 insertions(+), 24 deletions(-)
---
diff --git a/gtk/gactionobserver.c b/gtk/gactionobserver.c
index babd38a..3f05c4a 100644
--- a/gtk/gactionobserver.c
+++ b/gtk/gactionobserver.c
@@ -118,7 +118,7 @@ g_action_observer_action_enabled_changed (GActionObserver *observer,
* @state: the new state of the action
*
* This function is called when an action that the observer is
- * registered to receive events for changes its state.
+ * registered to receive events for changes to its state.
*
* This function should only be called by objects with which the
* observer has explicitly registered itself to receive events.
diff --git a/gtk/gtkaccelmap.c b/gtk/gtkaccelmap.c
index 8dcdc5b..7154b40 100644
--- a/gtk/gtkaccelmap.c
+++ b/gtk/gtkaccelmap.c
@@ -955,7 +955,7 @@ _gtk_accel_map_remove_group (const gchar *accel_path,
*
* Note that locking of individual accelerator paths is independent from
* locking the #GtkAccelGroup containing them. For runtime accelerator
- * changes to be possible both the accelerator path and its #GtkAccelGroup
+ * changes to be possible, both the accelerator path and its #GtkAccelGroup
* have to be unlocked.
*
* Since: 2.4
diff --git a/gtk/gtkcellarea.c b/gtk/gtkcellarea.c
index c9d6a7a..df9c709 100644
--- a/gtk/gtkcellarea.c
+++ b/gtk/gtkcellarea.c
@@ -2075,8 +2075,8 @@ gtk_cell_area_get_request_mode (GtkCellArea *area)
*
* Retrieves a cell area's initial minimum and natural width.
*
- * @area will store some geometrical information in @context along the way,
- * when requesting sizes over an arbitrary number of rows, its not important
+ * @area will store some geometrical information in @context along the way;
+ * when requesting sizes over an arbitrary number of rows, it's not important
* to check the @minimum_width and @natural_width of this call but rather to
* consult gtk_cell_area_context_get_preferred_width() after a series of
* requests.
@@ -2151,8 +2151,8 @@ gtk_cell_area_get_preferred_height_for_width (GtkCellArea *area,
*
* Retrieves a cell area's initial minimum and natural height.
*
- * @area will store some geometrical information in @context along the way,
- * when requesting sizes over an arbitrary number of rows, its not important
+ * @area will store some geometrical information in @context along the way;
+ * when requesting sizes over an arbitrary number of rows, it's not important
* to check the @minimum_height and @natural_height of this call but rather to
* consult gtk_cell_area_context_get_preferred_height() after a series of
* requests.
diff --git a/gtk/gtkcellareacontext.c b/gtk/gtkcellareacontext.c
index 910e92b..f464c3a 100644
--- a/gtk/gtkcellareacontext.c
+++ b/gtk/gtkcellareacontext.c
@@ -30,7 +30,7 @@
* #GtkTreeModel rows that are requested and rendered in the same context.
*
* #GtkCellLayout widgets can create any number of contexts in which to
- * request and render groups of data rows. However its important that the
+ * request and render groups of data rows. However, it's important that the
* same context which was used to request sizes for a given #GtkTreeModel
* row also be used for the same row when calling other #GtkCellArea APIs
* such as gtk_cell_area_render() and gtk_cell_area_event().
@@ -329,12 +329,12 @@ gtk_cell_area_context_real_allocate (GtkCellAreaContext *context,
*
* Fetches the #GtkCellArea this @context was created by.
*
- * This is generally unneeded by layouting widgets; however
+ * This is generally unneeded by layouting widgets; however,
* it is important for the context implementation itself to
* fetch information about the area it is being used for.
*
* For instance at #GtkCellAreaContextClass.allocate() time
- * its important to know details about any cell spacing
+ * it's important to know details about any cell spacing
* that the #GtkCellArea is configured with in order to
* compute a proper allocation.
*
diff --git a/gtk/gtkcellrenderer.c b/gtk/gtkcellrenderer.c
index 78fb31c..9f4b4e2 100644
--- a/gtk/gtkcellrenderer.c
+++ b/gtk/gtkcellrenderer.c
@@ -46,7 +46,7 @@
* is rendered in the correct location using gtk_cell_renderer_render().
*
* There are a number of rules that must be followed when writing a new
- * #GtkCellRenderer. First and foremost, its important that a certain set
+ * #GtkCellRenderer. First and foremost, it's important that a certain set
* of properties will always yield a cell renderer of the same size,
* barring a #GtkStyle change. The #GtkCellRenderer also has a number of
* generic properties that are expected to be honored by all children.
diff --git a/gtk/gtkcellview.c b/gtk/gtkcellview.c
index 94169f9..d5d33ed 100644
--- a/gtk/gtkcellview.c
+++ b/gtk/gtkcellview.c
@@ -596,7 +596,7 @@ gtk_cell_view_size_allocate (GtkWidget *widget,
/* The first cell view in context is responsible for allocating the context at allocate time
* (or the cellview has its own context and is not grouped with any other cell views)
*
- * If the cellview is in "fit model" mode, we assume its not in context and needs to
+ * If the cellview is in "fit model" mode, we assume it's not in context and needs to
* allocate every time.
*/
if (priv->fit_model)
@@ -993,7 +993,7 @@ gtk_cell_view_new_with_context (GtkCellArea *area,
* @text: the text to display in the cell view
*
* Creates a new #GtkCellView widget, adds a #GtkCellRendererText
- * to it, and makes its show @text.
+ * to it, and makes it show @text.
*
* Return value: A newly created #GtkCellView widget.
*
@@ -1058,8 +1058,8 @@ gtk_cell_view_new_with_markup (const gchar *markup)
* gtk_cell_view_new_with_pixbuf:
* @pixbuf: the image to display in the cell view
*
- * Creates a new #GtkCellView widget, adds a #GtkCellRendererPixbuf
- * to it, and makes its show @pixbuf.
+ * Creates a new #GtkCellView widget, adds a #GtkCellRendererPixbuf
+ * to it, and makes it show @pixbuf.
*
* Return value: A newly created #GtkCellView widget.
*
diff --git a/gtk/gtkicontheme.c b/gtk/gtkicontheme.c
index 5f8089f..c79826c 100644
--- a/gtk/gtkicontheme.c
+++ b/gtk/gtkicontheme.c
@@ -109,7 +109,7 @@
* or stock items, rather than directly, but looking up icons
* directly is also simple. The #GtkIconTheme object acts
* as a database of all the icons in the current theme. You
- * can create new #GtkIconTheme objects, but its much more
+ * can create new #GtkIconTheme objects, but it's much more
* efficient to use the standard icon theme for the #GdkScreen
* so that the icon information is shared with other people
* looking up icons. In the case where the default screen is
diff --git a/gtk/gtkspinbutton.c b/gtk/gtkspinbutton.c
index c20a69f..2e071d9 100644
--- a/gtk/gtkspinbutton.c
+++ b/gtk/gtkspinbutton.c
@@ -2407,7 +2407,7 @@ gtk_spin_button_set_value (GtkSpinButton *spin_button,
* @policy: a #GtkSpinButtonUpdatePolicy value
*
* Sets the update behavior of a spin button.
- * This determines wether the spin button is always updated
+ * This determines whether the spin button is always updated
* or only when a valid value is set.
*/
void
diff --git a/gtk/gtktestutils.c b/gtk/gtktestutils.c
index 4a679a6..c41c892 100644
--- a/gtk/gtktestutils.c
+++ b/gtk/gtktestutils.c
@@ -130,7 +130,7 @@ test_find_widget_input_windows (GtkWidget *widget,
* particular because the mouse pointer is warped to the key press
* location, see gdk_test_simulate_key() for details.
*
- * Returns: wether all actions neccessary for the key event simulation were carried out successfully.
+ * Returns: whether all actions neccessary for the key event simulation were carried out successfully.
*
* Since: 2.14
**/
@@ -166,7 +166,7 @@ gtk_test_widget_send_key (GtkWidget *widget,
* particular because the mouse pointer is warped to the button click
* location, see gdk_test_simulate_button() for details.
*
- * Returns: wether all actions neccessary for the button click simulation were carried out successfully.
+ * Returns: whether all actions neccessary for the button click simulation were carried out successfully.
*
* Since: 2.14
**/
@@ -197,7 +197,7 @@ gtk_test_widget_click (GtkWidget *widget,
* spin button arrow areas, usually leading to an increase or decrease of
* spin button's value.
*
- * Returns: wether all actions neccessary for the button click simulation were carried out successfully.
+ * Returns: whether all actions neccessary for the button click simulation were carried out successfully.
*
* Since: 2.14
**/
diff --git a/gtk/gtktoolitem.c b/gtk/gtktoolitem.c
index 1671753..90ba2fd 100644
--- a/gtk/gtktoolitem.c
+++ b/gtk/gtktoolitem.c
@@ -1409,7 +1409,7 @@ gtk_tool_item_toolbar_reconfigured (GtkToolItem *tool_item)
/* The slightely inaccurate name "gtk_tool_item_toolbar_reconfigured" was
* choosen over "gtk_tool_item_tool_shell_reconfigured", since the function
* emits the "toolbar-reconfigured" signal, not "tool-shell-reconfigured".
- * Its not possible to rename the signal, and emitting another name than
+ * It's not possible to rename the signal, and emitting another name than
* indicated by the function name would be quite confusing. That's the
* price of providing stable APIs.
*/
diff --git a/gtk/gtkwidget.c b/gtk/gtkwidget.c
index 47b3e26..37460e3 100644
--- a/gtk/gtkwidget.c
+++ b/gtk/gtkwidget.c
@@ -7503,13 +7503,13 @@ gtk_widget_set_receives_default (GtkWidget *widget,
* gtk_widget_get_receives_default:
* @widget: a #GtkWidget
*
- * Determines whether @widget is alyways treated as default widget
- * withing its toplevel when it has the focus, even if another widget
+ * Determines whether @widget is always treated as the default widget
+ * within its toplevel when it has the focus, even if another widget
* is the default.
*
* See gtk_widget_set_receives_default().
*
- * Return value: %TRUE if @widget acts as default widget when focussed,
+ * Return value: %TRUE if @widget acts as the default widget when focussed,
* %FALSE otherwise
*
* Since: 2.18
diff --git a/gtk/gtkwindow.c b/gtk/gtkwindow.c
index fe24363..99bab05 100644
--- a/gtk/gtkwindow.c
+++ b/gtk/gtkwindow.c
@@ -6576,7 +6576,7 @@ gtk_window_compute_configure_request_size (GtkWindow *window,
info->resize_height > 0 ? height : NULL);
}
- /* Don't ever request zero width or height, its not supported by
+ /* Don't ever request zero width or height, it's not supported by
gdk. The size allocation code will round it to 1 anyway but if
we do it then the value returned from this function will is
not comparable to the size allocation read from the GtkWindow. */
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]