[hyena] SafeUri: rename parameter to be less confusing



commit 8ba7e7415cb939fcd4fe79a5993b774a58e7439b
Author: Andres G. Aragoneses <knocte gmail com>
Date:   Sat Jul 7 13:10:56 2012 +0100

    SafeUri: rename parameter to be less confusing
    
    The ctor overload that accepts both file names and URIs via string
    has a second bool parameter 'isUri' to distinguish them, therefore
    it is confusing to call the first parameter just "uri".
    
    This commits renames it to "uriOrFilename".

 Hyena/Hyena/SafeUri.cs |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)
---
diff --git a/Hyena/Hyena/SafeUri.cs b/Hyena/Hyena/SafeUri.cs
index 0afa310..a3da08b 100644
--- a/Hyena/Hyena/SafeUri.cs
+++ b/Hyena/Hyena/SafeUri.cs
@@ -60,16 +60,16 @@ namespace Hyena
             }
         }
 
-        public SafeUri (string uri, bool isUri)
+        public SafeUri (string uriOrFilename, bool isUri)
         {
-            if (String.IsNullOrEmpty (uri)) {
-                throw new ArgumentNullException ("uri");
+            if (String.IsNullOrEmpty (uriOrFilename)) {
+                throw new ArgumentNullException ("uriOrFilename");
             }
 
             if (isUri) {
-                this.uri = uri;
+                this.uri = uriOrFilename;
             } else {
-                this.uri = FilenameToUri (uri);
+                this.uri = FilenameToUri (uriOrFilename);
             }
         }
 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]