[gtk+/gtkbuilder-gbinding] (145 commits) ...Introduce gtk_builder_create_bindings[_full](), add transformation function support
- From: Denis Washington <denisw src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk+/gtkbuilder-gbinding] (145 commits) ...Introduce gtk_builder_create_bindings[_full](), add transformation function support
- Date: Sat, 23 Jul 2011 09:08:25 +0000 (UTC)
Summary of changes:
06b1362... gtkaccelmap: the data gtk_accel_map_foreach needs to be ann (*)
05eb411... a11y: Fix warnings when removing widgets that don't have ac (*)
ccaa0af... filechooser: Fix set-but-not-used warning from gcc (*)
2aeb704... Drop the fake GailUtil subclass (*)
dc8d64d... Add a forgotten static (*)
88537fb... Another forgotten static (*)
6715652... Another forgotten static (*)
d98622b... Reduce the number of unwanted exports (*)
3846a59... Drop a few more unwanted exports (*)
4d17ff9... GtkAssistant doesn't notice destroyed pages (*)
0746145... Convert GailCell to GtkCellAccessible (*)
1da67a2... Convert GailContainerCell to GtkContainerCellAccessible (*)
3688c1a... Convert GailBooleanCell to GtkBooleanCellAccessible (*)
920c1c4... Convert GailRendererCell to GtkRendererCellAccessible (*)
7ddf0df... Convert GailImageCell to GtkImageCellAccessible (*)
4e5629b... Convert GailTextCell to GtkTextCellAccessible (*)
ddfa756... Convert GailCellParent to GtkCellAccessibleParent (*)
a20c7ed... Avoid unnecessary includes (*)
9f58645... Avoid compiler warnings (*)
1803e1b... Avoid compiler warnings (*)
8831231... Avoid more compiler warnings (*)
634e95e... Avoid more shadowing warnings (*)
07380c1... Make all of a11y/ compile with -Wshadow (*)
9586305... Updated Spanish translation (*)
6c6dab9... Updated POTFILES.in (*)
207c485... Updated Spanish translation (*)
b81826f... Updated Spanish translation (*)
d55728c... Updated Galician translations (*)
8f9493d... a11y: Make menuitem accessible return ROLE_MENU when it has (*)
a82cbf2... a11y: Don't advertise ROLE_MENU in submenuitems (*)
17d5afc... a11y: Only advertise action if menuitems are selectable (*)
375eb8e... tests: Add a test for menus (*)
ad9da27... GMountOperation::show-processes support for OpenBSD using k (*)
86fcb8b... Add gtk_assistant_remove_page (*)
bf70fbb... Drop an unneeded include (*)
91bfe9f... Make gtk_container_remove work for assistants (*)
5556ae9... Don't install any gail headers (*)
08e62ba... Add a test for atk_get_root() (*)
afd0726... Updated Norwegian bokmÃl translation (*)
f1ca0ee... Log to recent-files when confirming the file chooser (*)
5a7335c... Updated Latvian translation. (*)
754a107... Updated Latvian translation. (*)
611104b... Updated Polish translation (*)
a32be5d... Don't include unistd.h unconditionally (*)
8b8070e... Update VS 2010 property sheet (*)
e472469... [l10n] Updated German translation (*)
afc6aa8... [l10n] Updated German translation (*)
b53f602... Save selection to recent-files in the asynchronous Save cas (*)
9a212b3... Add a getter for the accessible type of a widget class (*)
5ab8120... Added VS projects for a11y and libgail-util (*)
cbc593b... Dist the VS 2008 a11y/libgail-util projects (*)
86794ce... Bug 653450 - gtkfilechooser crashes when added favorite (*)
88a18a2... quartz: Remove call to deprecated gdk_pointer_ungrab (*)
d8c00cd... Revert "Add a getter for the accessible type of a widget cl (*)
3e05518... Drop unneeded includes (*)
7c2414e... Drop private GtkAccessible api (*)
3cc22ee... Add some GtkAccessible documentation (*)
b5f4a56... Updated Hebrew translation. (*)
1f264dd... Don't use deprecated style api (*)
f90c154... gdk/x11: Add gdk_x11_device_get_id() (*)
6aab48e... gdk/x11: Add gdk_x11_device_manager_lookup() (*)
b5f3014... x11: Skip GenericEvents with no cookie data in the xi2 devi (*)
7741f5a... theming-engine: Adjust register_property() to recent glib c (*)
102faa3... GtkLabelAccessible: avoid extra selection-changed emissions (*)
ffa112d... Add an initial focus testbed (*)
69e594f... Updated Lithuanian translation. (*)
bb4c98b... Updated Lithuanian translation. (*)
25a4e8e... Don't return a value from a void function (*)
dc2ae6c... Don't emit a nonexisting signal (*)
e756b2e... Use canonical names (*)
095ea84... Make destroying assistants work again (*)
2da37ba... Don't run testfocus in 'make check' (*)
f9c4977... Update expected test output (*)
2b5140c... Avoid a compiler warning (*)
6d33c78... Get rid of the focus_gtk vfunc (*)
3bfa69f... Don't use object data for layer (*)
1f4b524... assistant: Use gtk_container_remove() when removing pages (*)
54e1caa... a11y: Remove separator menu item special case (*)
c0df6f9... menushell: Use GtkMenuShellAccessible as a11y object (*)
b17ad13... API: Add gtk_widget_class_set_accessible_role() (*)
8815ccf... calendar: Use gtk_widget_class_accessible_set_role() (*)
017d02b... hsv: Use gtk_widget_class_accessible_set_role() (*)
094785b... separator: Use gtk_widget_class_accessible_set_role() (*)
b61a200... separatormenuitem: Use gtk_widget_class_accessible_set_role (*)
9c81336... widget: Reset the accessible role when a new accessible typ (*)
299b3be... filechooserdialog: Use gtk_widget_class_set_accessible_role (*)
2e57013... colorsel: Use gtk_widget_class_set_accessible_role() (*)
6379faa... dialog: Use gtk_widget_class_set_accessible_role() (*)
c40875a... messagedialog: Use gtk_widget_class_set_accessible_role() (*)
27f9682... fontsel: Use gtk_widget_class_set_accessible_role() (*)
480b586... plug: Use gtk_widget_class_set_accessible_role() (*)
d9bfa56... tearoffmenuitem: Use gtk_widget_class_set_accessible_role() (*)
96245d4... viewport: Use gtk_widget_class_set_accessible_role() (*)
9c30ae0... toolbar: Use gtk_widget_class_set_accessible_role() (*)
f2626b6... menubar: Use gtk_widget_class_set_accessible_role() (*)
0c9b046... accellabel: Use gtk_widget_class_set_accessible_role() (*)
d5ef844... checkbutton: Use gtk_widget_class_set_accessible_role() (*)
438b78a... a11y: Remove gtkradiomenuitemaccessible.[ch] (*)
fa16a54... a11y: Rename radiosubmenuitem to radiomenuitem (*)
77f411c... a11y: Remove gtkcheckmneuitemaccessible.[ch] (*)
9306b26... a11y: Rename checksubmenuitem to checkmenuitem (*)
b0e836e... a11y: Merge gtksubmenuitem into gtkmenuitem (*)
fd705ce... progressbar: Fix a signed/unsigned comparison (*)
68ebc77... styleproperties: Add an unset vfunc to style properties (*)
6aa000f... styleproperties: Add unset functions for shorthands (*)
20c6acf... reftests: Add test for recent fix (*)
1cdb47d... notebook: Remove the homogenous private member variable (*)
cb34cfe... Updated Slovenian translation (*)
ebadb36... notebook: Remove unused private member variable (*)
0141651... css: Use the correct free function (*)
5eefc37... cssprovider: @import <string> is valid CSS (*)
b8465d2... cssprovider: Get the location right for semicolon warnings (*)
1a76304... cssprovider: Emit an error when parsing a binding fails (*)
15674c5... tests: Move stylecontext CSS tests (*)
75a43bb... tests: Move empty css parser test to new CSS tests (*)
dc01496... Update Visual Studio Project Files (*)
e24b186... Merge branch 'master' into gtkbuilder-gbinding
4ead7b6... Switch to g_format_size() (*)
5a1f371... cssprovider: Fix names for first and last child pseudo clas (*)
4f5e69f... tests: Fix whitespace between url and ( (*)
d314709... tests: Declare previously invalid CSS as valid now (*)
9e36bea... styleproperty: An unnamed engine equals the default engine (*)
b0b287f... themingengine: Use the default way of indicating privates (*)
a02b820... tests: Remove unused file from EXTRA_DIST (*)
b3f03d0... roundedbox: Clamp border radius to box size (*)
db66618... reftests: Add test for border radius clamping (*)
5a1e157... styleproperty: dump image surfaces as PNG data URLs (*)
72bc10a... css: Ensure that font shorthand parsing sets font name and (*)
9062060... css: Don't print both border-image-repeat values when they' (*)
47635a2... themingengine: Return NULL for nonexistant theming engines (*)
d56e8c8... tests: Move declaration tests to new test infrastructure (*)
b2d679a... configure.ac: Bump glib required version (*)
91706f7... Don't use deprecated G_UNICODE_COMBINING_MARK (*)
0388781... XK_Num_Lock is called GDK_KEY_Num_Lock in this source tree. (*)
edcce8e... Updates for 3.1.10 (*)
71a70a7... Use generic marshaler (*)
0b4d843... Bug 654266 â No longer possible to set empty text on a Gt (*)
d82aeb8... tests: Fix stylecontext test that we changed semantics for (*)
a03ab23... Keep building libgail-util docs for now (*)
b555a97... Drop non-existing functions (*)
f7e927b... Try to make the docs build again (*)
ec72283... some minor doc fixes (*)
1171696... More updates (*)
65a846b... Merge branch 'master' into gtkbuilder-gbinding
173bd16... Introduce gtk_builder_create_bindings[_full](), add transfo
(*) This commit already existed in another branch; no separate mail sent
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]