[rygel] Created tag RYGEL_0_4
- From: Zeeshan Ali Khattak <zeeshanak src gnome org>
- To: svn-commits-list gnome org
- Cc:
- Subject: [rygel] Created tag RYGEL_0_4
- Date: Wed, 23 Sep 2009 19:43:34 +0000 (UTC)
The signed tag 'RYGEL_0_4' was created.
Tagger: Zeeshan Ali (Khattak) <zeeshanak gnome org>
Date: Wed Sep 23 22:34:35 2009 +0300
Release 0.4
Changes since the last tag 'RYGEL_0_3':
James Henstridge (7):
Add support for time-based seeking in transcoded streams.
core: Fix a typo.
core: Add new ignore rules
core: bitrate should be in bytes/second
core: Expose transcode formats in the ProtocolInfo
core: Push creation of gst source to MediaItem
core: Refactor: request handling into separate interface
Jens Georg (117):
media-export: fix crash if nothing was configured
core: Revert "Remove MetadataExtractor class."
core: Make extractor compile
core: Collect tags and emit them en-block when done
core: Replace properties with internal queue
core: Add custom tags to taglist for extra info
core: Add error event for failing files
core: Add simple Queue convenience class based on Gee.ArrayList
core: Fix TagName != structure key
core: Handle error in extract_mime_and_size
core: Use fake sinks for playbin to suppress window popup on video
core: Add basic media database class
core: Implement saving of item in database
core: Allow parentless Media item
core: Add missing file
core: Add item retrieval method
core: Add missing item duration to table
core: more db schema fixes
core: Add get_children and get_object method
core: Make MetadataExtractor public in vapi
core: issue File if finished, not uri
core: Replace homegrown queue with GLib's
core: for all children set container as parent
core: fix bogus return statement
core: add uris to items when fetched from db
core: Fix query for objects regargind left outer join semantics
core: Fix join in query and giving child correct id
core: never return null children list; use empty list instead
core: add function to query child count from database
core: initialize database backed container with correct child count
core: move uris from MediaItem to MediaObject
core: Create directory of database if not already existing
core: get rid of parentless media item
core: Revert "core: Allow parentless Media item"
media-export: Add media harvester class
core: add existence check for object to db
media-export: remove unused classes
media-export: remove debug output
media-export: fix id calculation
media-export: fix child count reporting
core: add basic sorting
media-export: get rid of third queue
media-export: cleanup root container descendency
core: update child count if container is updated
media-export: notify about updates
media-export: skip files/folders starting with '.'
core: rename database strings
core,media-export: Rename DatabaseBackedMediaContainer
build: Fix build with automake-1.11
build: Fix out-of-tree builds
build: Use automake-1.11's vala support
build: add GEN prefix for rygel.conf
core: refine sorting of elements
core,media-export: MediaDB name is just a name
core: add some documentation
media-export: Add recursive file monitor
media-export: hook up file monitor
media-export: harvest newly added files
media-export: Add uri to container objects
core: add deletion of items to media-db
media-export: react on deletion of files
core: change table key relationships
core: add update methods
core: add timestamp to MediaObject
media-export: Add mtime of object into database
core: Add timestamp to exists function
core: Add function to get list of child ids
media-export: delete gone directories on new start
core: Add check if no parent exists
media-export: Add root container to database
media-export: Notify parent container on removal
media-export: update changed files, not re-add
media-export: do file type query async
media-export: remove harvester if done harvesting
core: don't delete root container when in db
core: fix #588034
media-export,mediathek: Root-Container-Singleton
media-export: avoid crash if unknown file is found
core, media-export: Handle invalid database files
media-export: Update documentation
media-export: Use null container for Harvesting
core: Handle more database error cases
media-export: Catch additional database errors
core: Add database upgrade code
mediathek: fix crash if not config is available
media-export: Add simple dbus service
core: Use MediaItem.add_uri
core: handle database error gracefully
core: handle database error gracefully
core,media-export: Rename MediaObject.timestamp
core: s/object_id/child_id/ for "get_child_*"
core: use MediaDBError more consistently
core: use fixed string for cache dir
media-export: bitrate is byte/s
media-export: Fix critical warnings
media-export: add assertion instead of comment
media-export: rename harvest to harvester
media-export: Fix warnings
media-export: cleanup
core: Add general signals for objects
core: Complete API of media-db
core: create_with_factory always used default factory
core: Use INVALID_TYPE error instead of GENERAL_ERROR
core: fix signal emission on added container
core: Rethrow database errors
core: Fix wrongly bound SQL for containers
media-export: Clarify which queue we want
media-export: Do not try to re-add container to db
core: Remove warning on unusable input
core: use playbin2 for meta-data if available
media-export: persist the uris added via DBus
media-export: Adapt to delete_ to remove_ rename
core: make arguments signed
media-export: Use a custom container for DBus
media-export: Add GetUris DBus command
core: be more robust while scanning metadata
core: update news file
Ole André Vadla Ravnås (1):
folder: No need to escape the URIs
Thijs Vermeir (3):
test: create the pipeline in a more simple way
gstlaunch: add new plugin that shares gstreamer launch lines
gstlaunch: use the default rygel configuration file
Zeeshan Ali (Khattak) (279):
core: *MediaServer* -> *RootDevice*
core: Rename create_root_device() to create()
core,plugins: Support all types of devices
core: Rename description.xml to MediaServer2.xml
Update README to reflect the Rygel homepage
ui: Change the name/title of an option
mediathek: Forgotten API update
ui: Pass '-export-dynamic' flag to linker
ui: Treeview to handle 'folders' option
ui: Implement removal of folder paths
folder: save implementation should chain-up
ui: Implement adding of Folder URIs
ui: Hint the window is a Dialog
ui: Connect signals from UI description as much as possible
ui: More like a GNOME preferences dialog
ui: Beautification
ui: Don't use signal autoconnection magic
folder: Rename to MediaExport
media-export: Remove trailing whitespaces
core: autogen.sh enables build for all plugins
media-export: Minor indentation fix
media-export: Cast the list to match return value
media-export: Rename 'items' to 'children'
media-export: Correct the RootContainer docs
media-export: Rename a local variable
media-export: Update docs for Container constructor
media-export: More use of 'this' keyword.
media-export: Use generic types/names
media-export: Provide a custom MediaItem class
media-export: Root container should handle items
media-export: Remove redundant 'using' statements
media-export: Asynchronously populate root container
core,ui: Updates based on renaming of Folder plugin
core: Nice default title for Tracker and MediaExport
core,ui,media-export: No more specific to folders
media-export: Add forgotten custom item class
ui: Don't set width of GtkNotebook
ui: Tooltips for plugin title entries.
core: Fix a typo in gconf schema file
core: Correct foaf:mbox in doap file
core: Update description in doap file
core: Set bitrate of mpeg2 video encoder to 30Mbps
core: Provide DBus service
core: Provide DBus service file
ui: Provide .desktop file for rygel-preferences
core: Provide .desktop file for Rygel
core,ui: Minimal handling of "Enable UPnP/DLNA"
core: Explicitly link to dbus-glib
core: Start/shutdown rygel when upnp is enabled/disabled
core: Expose desktop dir path to source code
core: Add Rygel to user's autostart list
core: Make symlink instead of copying desktop file
core: Remove Rygel from user's autostart list
core: Refactor Configuration.upnp_enabled setter
core: Add 'general/enabled' key to schemas file
core: Configuration is now an interface
core: Re-introduce Configuration impl. as UserConfig
core: Errors for Configuration
core,ui: Error out if value not available in config
core,ui: Turn Configuration props into getter/setter
core,plugins: Implement and use MetaConfiguration
core: Catch more generic error
core: Initialize the thread system
core: Expose more build options to vala world
core: Basic implementation of CmdlineConfig
core: Add '--disable-plugin' commandline option
core: Indentation fixes
core: Commandline option to set plugin title
core: Don't use same short option twice
core: Handle dynamic (plugin) options
core: Separate option tokens by ":" rather than ","
core: Handle string list options
core: Handle int list options
ui: Tracker options to share type of media
core: Add new Tracker options to schemas file
core: configure option to enable maemo support
core: Special schemas file for maemo
core: MP2TSTranscoder uses 720p rather than 1080i
core: Reduce bitrate of mpeg2 video encoder to 3Mbps
core: Tell the assumed protocol when probe fails
core: Don't spam the user's config dir
core: Remove a redundant 'using' statement
core,plugins,ui: `make clean` don't clean generated files
core: Add forgotten files to BUILT_SOURCES
core,plugins,ui: Fix self-contradiction in headers
core,ui,dvb: Remove DVB plugin
core: Update README according to recent changes
core: Refer to file by path not name
core: Add all schema files to distribution
core: Enable LCPM transcoding for maemo
tracker: Better detection of Tracker availability
core: Require GStreamer >= 0.10.23
core: Don't use @REALNAME@ on Maemo
core: Disable MediaExport plugin on Maemo for now
core: Add 'dlna_profile' to MediaItem
external: Make use of 'DLNAProfile' property
ui: Catch error when getting URIs from config
ui: Separate out try/catch blocks
core: Allow owned refs to parent container
core: Use 'this' keyword.
core: Implement filtered-browse.
core: Take care of property prefixes in filter
core: No need to refer by full path
core: "upnp:class" is mandatory property.
core: Rename Filter to BrowseFilter
core: Minor re-formatting to reduce LOCs
core: Assume parent of parentless item to be root
core: Attributes imply inclusion of associated prop
core: Apply browse filter to 'res' attributes
core: Put BrowseFilter class in separate file
core: Clear 'serviceList' before adding services
media-export: Remove extra "-media" from filenames
external: Don't load the plugin more than once
core: Correctly handle top-level attributes
core: Provide 'childCount' only when requested
tracker: Clamp the index and offset
core: Bump-up vala requirement to 0.7.4
core: Expose sysconfdir to vala world
core,plugins,ui: Move from GConf to .ini file usage
ui: Explicitly link to dbus-glib
ui: "port" key is now also optional
ui: Put failable calls in separate try/catch blocks
core: Provide configuration saving API
ui: keep and save the configuration in the end
core: Don't lose translations/comments in config
ui: Don't use the default singleton
core,ui: Diff between read-only and writable config
core: Minor indentation fix
core: Correct condition for system config loading
core: Install config file in system config dir
core: Templates for config file
core: Remove gconf schema files
core: Remove gconf stuff from configure.ac
core: Use the correct config file
external: Utilize optional MediaItem properties
Require gupnp 0.13
core: RootDeviceFactory.context is now public
core: RootDeviceFactory doesn't create context
core: Multiple/dynamic network handling
core: Minor indentation fix
core: Bump-up gupnp-vala requirment to 0.5.5
core: Useful debug messages on context (un)availability
core: Can't remove from ArrayList during iteration
core: Make the device unavailable before removing
core: Move context.host_path call to RootDeviceFactory
ui: Saner defaults for FileChooserDialog
ui: Show paths instead of URIs whenever possible
core: No need to keep path of config file around
core: (Un)pause the SoupMessage at the right time
core: No need to mark the device unavailable
Asynchronously wait for state change
core: Get rid of remainder of gconf usage
core: And still the removal of gconf usage
build: unify and hence simplify core build
build: Indentation fixes
build: Remove forgotten redundant rule
Shave the output
core: Indentation/coding style fixes for last commit
core: ProtocolInfo provided by TranscodeManager
core: TranscodeManager shouldn't know about protocol
core: Use the new GSSDP/GUPnP APIs
core: Require next gupnp-vala release
core: Use destroyer instead of keeping a weak_ref
core: Copy the plugin list before creating devices
core: Add factory before creating devices from it
core: Copy the factory list before creating devices
core: Adapt to new gupnp and gupnp-av APIs
core: Require latest gupnp-av (0.5)
core: Don't create iconList element if it exists
core: Set bitrate on MP2TS transcoding res
core: Pass MediaItem to Transcoder.create_source()
core: Pass the items all the way to TranscoderBins
core: Add pixel-aspect-ratio props to MediaItem
core: Use the correct pixel-aspect-ratio
core: Add Transcoder.get_distance()
core: A small indentation fix
core: Better distance calculation for transcoders
core: List the resources according to compatiblity
core: Minor non-functional fixes
core: Minor refactoring of MediaItem class
core: Add MediaItem.get_protocol_info()
core: Add HTTPTranscodeHandler
core: IdentityRequestHandler -> HTTPIdentityHandler
core: Random asthetic fixes
core: Rename Seek to HTTPSeek
core: Move seek errors to HTTPSeekError
core: HTTPRequest.http_server is now public prop
core: Param uri of MediaItem.add_resource is now nullable
core: MediaItem.get_protocol_info is now private
core: Provide contentFeatures.dlna.org header
core: Turn HTTPRequestHandler into abstract class
core: Merge two methods of HTTPRequestHandler
core: Add disclaimer for some ugly-looking code
core,plugins: Remove redundant statement
core: Error on wrong "getcontentFeatures.dlna.org"
core: Hide internal API
core: Early protocol detection
core: HTTPServer.context is now public property
core: Only advertise internal URIs on lo
core: Correctly handle unset port in configs
core,data: Version D-Bus interface, path and service
core: Set DLNA transferMode header on responses
core,ui,data: Replace 'ip' config with 'interface'
data,ui: Glade-3 mood swings
core: Allow plugins to provide thumbnails
core: Very minor refactoring
core,tracker: Derive Thumbnail from IconInfo
core: Add Thumbnailer
core: Thumbnailer should be singleton
core: Minor refactor
core,plugins: Simpler way to provide thumbnails
core: Expect 'jpeg' extension for thumbnail files
mediathek: Remove trailing whitespace
tracker: Only set size of image item, once
external: Prefix IDs with type of object
external: Fetch items on demand
external: Fix some typos
core: Minor coding-style fix
core: Set db to null on failure
core: Declare signals on the top in one place
core: Add signals for container operations
core: MediaDB.save_item/container are now public
media-export: Remove redundant try/catch
build: Bump-up vala requirement to 0.7.6
build: Bump-up libgee requirement to 0.3.0
core: AsyncReadyCallback.source_object is nullable
media-export: AsyncReadyCallback.source_object is nullable
core: A simple MediaContainer implementation
core: Provide SimpleContainer.root
tracker: Derive TrackerRootContainer from SimpleContainer
core: Micro indentation fix
core: cancellable is now a prop of StateMachine
core: More generic ObjectSearch class
core: Micro indentation fix
core: Rename ObjectSearch to MediaObjectSearch
core: Move MediaObjectSearch into separate module
core: MediaObjectSearch provides error
tracker: Better titles for top-level folders
tracker: Introduce "Albums" and "Artists" containers
tracker: Remove TrackerCategory.child_class
tracker: Rename TrackerCategory.category to service
tracker: TrackerCategory -> TrackerSearchContainer
tracker: Items should know their service
tracker: create_item implemented by SearchContainer
tracker: Minor refactoring
tracker: item's ID keeps the service
tracker: Add SearchContainer.query_condition
tracker: MediaItem provides metadata keys
tracker: SearchContainer is not abstract anymore
tracker: Remove now redundant classes
tracker: SearchContainer() takes query as argument
tracker: Populate MetadataContainer children
build: Require vala trunk
core: AsyncReadyCallback.source_object is nullable
tracker,external: Don't errors out object not found
core: Check if ArrayList is empty
tracker: Correct a typo
tracker: Add missing return statement
tracker: Be more specific about error thrown
tracker: Rename a constant
tracker: Use 'equals' as op in RDF query
tracker: Ignore empty metadata values
tracker: SearchContainer takes keywords
tracker: Add TrackerKeywords
tracker: Make use of default value magic in Vala
tracker: Don't list items in descending order
plugins: Make use of SimpleContainer
gstlaunch: Refactor and beautify!
core,plugins: Add add_child & remove_child to SimpleContainer
media-export: No need for a separate D-Bus service
data: Use hostname on maemo
build: Supress all CC warnings by default
media-export: Minor indentation fixes
media-export: Title starts with capital letter
media-export: Keep const in the associated class
media-export: Some code cleanup
core: Update the project description
core: Prepare NEW file for release 0.4
core: More corrections to release log
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]