[vte] Created tag 0.21.5



The signed tag '0.21.5' was created.

Tagger: Behdad Esfahbod <behdad behdad org>
Date: Tue Sep 8 11:35:08 2009 -0400

    0.21.5

Changes since the last tag '0.21.4':

Behdad Esfahbod (71):
      [ring] Cleanup debug messages
      [ring] Add _vte_ring_move()
      [ring] Update docs
      [ring] Don't free items when inserting, reuse them
      [ring] Simplify insert
      [ring] Add safeguards to remove()
      Simplify code
      Simplify remove
      Simplify insert
      [ring] Simplify insert and remove even more
      Abstract rowdata functions away from GArray
      Add basic_cell with default cell attrs
      Simplify a bit
      Rename _vte_row_data_set_length() to _vte_row_data_shrink()
      [ring] Simplify more
      [ring] Swap rows instead of moving
      Remove ring from test programs
      Minor cleanup
      [ring] Fix brokenness with macro implementation
      Remove cell.attr.fragment and use cell.c == FRAGMENT instead
      Enable silent rules by default
      Bug 594025 -  crash in Terminal: running cat /dev/urandom...
      Remove chunk mutex
      [ring] Remove GArray for rowcell allocation
      Rename vtecell to VteCell as it's not a value type
      Rename vtecells to VteCells as well
      [ring] Use large-size pools for rowdata allocation
      Minor cleanup
      [ring] Add debug messages to new code
      [ring] Set minimum row size for allocation to 80
      [ring] Rename
      [ring] Tune pool allocation to allocate in powers of two in bytes
      [ring] Remove unused macro
      [ring] Minor cleanup
      [ring] Remove glong in favor of guint
      Add static assertions
      [ring] Assert struct sizes
      [ring] Allocate main row array in powers of two
      [ring] Simplify insert/remove
      Fix palette handling
      [ring] Keep ring->next instead of ring->length
      [ring] Overhaul.  Not working right now.
      [ring] Closer to working
      [ring] Compacting goodness; disabled now; eats babies
      Fix comment
      Fix initial scrollback size
      [ring] Almost working
      [ring] Store max_rows
      [ring] Enlarge initial writable size
      [ring] Allow one more room in insert such that position doesn't fall off
      [ring] Ease default attr computations
      [ring] Cleanup warnings
      [ring] Minor
      Fix ring access const correctness
      [ring] Implement uncompact
      [ring] Move view cache row to ring
      [ring] Fix insert at start
      [ring] Add debug output
      [ring] Optimize attribute bitfield placement
      [ring] Invalidate cache
      [ring] Fix bytes_left calculation
      [ring] Fix chunk disposal
      [ring] Reduce free chunks from 10 to 4
      [ring] Free all spare chunks when all rings are destroyed
      [ring] Rename a bit
      [ring] Const correctness
      [ring] Fix signed issues
      [ring] Whitespace
      [ring] Reinstate attr.fragment
      Simplify access
      Release 0.21.5

Og B. Maciel (1):
      Updated mailing list address.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]