[gtk+] Created tag 2.19.0
- From: Matthias Clasen <matthiasc src gnome org>
- To: svn-commits-list gnome org
- Cc:
- Subject: [gtk+] Created tag 2.19.0
- Date: Mon, 2 Nov 2009 00:39:18 +0000 (UTC)
The unsigned tag '2.19.0' was created.
Tagger: Matthias Clasen <mclasen redhat com>
Date: Sun Nov 1 19:37:24 2009 -0500
GTK+ 2.19.0
Changes since the last tag '2.18.2':
A S Alam (1):
Completing translation for Punjabi
Adrian Johnson (1):
Take printer margins into account on Windows
Alexander Shopov (1):
Updated Bulgarian translation
André Gondim (1):
Updated Brazilian Portuguese translation.
Bastien Nocera (8):
Add ability to set a tooltip's image from a GIcon
Bug 319607 â?? Add a throbber (activity widget) to GTK+
Update POTFILES.in for spinner widgets
Capitalise a11y description for GtkSpinner
Fix "active" property not being notified
Add GtkSpinner::animation-duration style property
Fix property links in GtkSpinner
Fix GtkSpinner using style before it's set
Benjamin Otte (19):
move GtkFileSystemModel private stuff out of the private header
Implement new GtkFileSystemModel
Creating the model no longer fails
Simplify gtk_file_chooser_default_unselect_file()
Consolidate tree models for different browse modes
Replace the cell data computations
Clean up code to use the model directly
Use the GtkTreeSortable of the filesystem model
Load icons on-demand
Only query the absolutely necessary attributes
Make the filesystem model filter API use a GtkFileFilter
Add a constructor to filesystem model that does not monitor a directory
Don't count the "enter directory name" line as a selected file
Convert search to use a GtkFileSystemModel
Convert recent files to a GtkFileSystemModel
Use the faster accessor function in the sort functions
Enable the size column in recent files/search
Remove unused error argument from show_and_select_files()
Improve show_and_select_files() function
Branko KokanoviÄ? (1):
Updated Serbian translation
Christian Dywan (11):
Deprecate GtkInputDialog
Undefine GTK_DISABLE_DEPRECATED in testinput to keep it compiling
Added accesor for GTK_VIEWPORT (widget)->bin_window
Deprecate GtkCurve and GtkGammaCurve
Deprecated GtkNotebook tab packing
Only set the accesible label if it is non-empty
Allow removing all closures with gtk_accel_group_disconnect
Don't use structure fields of GtkAccelMap in GtkSocket
Don't use deprecated button signal functions in Gail
Don't use deprecated button signal functions in clist and combo
Deprecate functions according to deprecated GtkButton signals
Cody Russell (1):
Added editing_canceled property to GtkCellEditable
Daniel Nylander (1):
Updated Swedish translation
David Planella (2):
Updated Catalan translation
Updated Catalan translation
Debarshi Ray (1):
Use G_BEGIN/END_DECLS in gtkcellrendererspinner.h
Dumitru MiÈ?u Moldovan (2):
Updated Romanian translation
Updated Romanian translation
Eitan Isaacson (1):
Explicitly set the accessible name of GtkToolButton.
Emmanuele Bassi (1):
gtk-demo: Remove C99-ism from list_store example
Federico Mena Quintero (42):
g_error() as soon as we catch an invalid column type
Compute the node size only once to avoid the scary macro
Start with a file array with a resonable preallocated size
Complete the documentation string for _gtk_file_system_model_new()
Fix and tighten an assertion
Clarify an argument to g_file_enumerate_children_async()
Clarify the arguments to g_file_monitor_directory()
Clarify the comments that some fields in GtkFileSystemModel can be NULL
Make _gtk_file_system_model_add_file() static
Make _gtk_file_system_model_remove_file() static
Remove the dir_thaw_source while disposing the model
Clarify the code flow in gtk_file_system_model_got_files()
Show an error dialog when we can't read the folder's contents
Clarify the arguments to g_file_query_info_async()
Comment on how the file_lookup hash table gets rebuilt on demand
When removing a file, also remove it from the file_lookup hash table
When updating a file, handle the case where the old file info is the same as the new one
Factory out functions to emit row_inserted, row_changed, row_deleted
Fix thinko in node_should_be_visible()
Remove obsolete code to use a cached mime-type
Big comment on how GtkFileSystemModel works
Clarify array indexes vs. row numbers
Clarify a couple of spots with comments
Nothing to do for ref/unref_node
Clarify variable names in gtk_file_system_model_sort()
Free some missing fields in ::finalize()
Make the code match the docs in _gtk_file_system_model_clear_cache()
Remove obsolete comment
s/get_is_visible/iter_is_visible for clarity
In set_filter(), handle the case where the new filter is the same as the old filter
Make get_selected_file() return a ref'ed file
Fix typo in a comment
Comment that the column order needs to be kept in sync across two functions
Factor out function to set a fixed size for the icon cell renderers
Don't leak a treepath if the treeview is not populated yet
Make copy_attribute() a function instead of a macro
Clarify the arguments of g_file_query_info_async()
Put the list of column types in a macro
Fix a g_strdup_printf()
Oops, it's gsize, not GSize
Fix thinkos in which fields get used
bgo#563010 - Fix clearing the selection in GtkFileChooserButton
Javier Jardon (1):
Use G_STRLOC instead __FILE__ and __LINE__
Javier Jardón (40):
Remove deprecated GtkContainer function and macros
Bug 596019 - No accessors for GtkDialog buttons
Bump version to 2.19.0
Use g_object_ref/unref instead deprecated gdk_*_ref/unref functions
Substitute gtk_style_unref for g_object_unref in documentation example
Substitute gtk_widget_ref/unref with g_object_ref/unref
Move documentation from templates to inline comments: GtkAboutDialog
Move documentation from templates to inline comments: GtkAccelGroup
Move documentation from templates to inline comments: GtkActivatable
Move documentation from templates to inline comments: GtkAccesible
Move documentation to inline comments: GtkToolShell
Remove some unnused variables
Fix compilation warning
Fix a compilation warning
Fix a compilation warning
Fix some compilation warning
Fix some compilation warning
Fix a compilation warning
Fix a compilation warning
Fix compilation warnings: use G_GSIZE_FORMAT instead %i
Remove unused function
Fix a compilation warning: use NULL instead ""
Cast to fix compilation warning
Cast to gchar* to fix a compilation warning
Cast to gchar* to fix a compilation warning
Cast to gchar* to fix a compilation warning
Use G_STRFUNC instead __FUNCTION__
Use G_STRLOC instead __LINE__
Use G_STRFUNC instead __FUNCTION__
Use G_STRFUNC and G_STRLOC instead __FUNCTION__ and __FILE__
Use G_STRLOC instead __FILE__ and __LINE__
Fix warning: cast to gchar*
Fix warning: cast to gchar*
Remove statement with no effect
Fix warning: some casts to gchar*
Use "Since: 2.x" instead "Since 2.x"
Fix some compilation warnings
Fix warning: cast to gint*
Fix some compilation warnings
Fix warning: Initialize to TRUE the returned variable
Jorge González (2):
Updated Spanish translation
Updated Spanish translation
Kevin Peng (1):
GdkPixbuf loader for QTIF format
Khaled Hosny (1):
Updated Arabic translation
Kjartan Maraas (1):
Updated Norwegian bokmål translation
Kristian Rietveld (17):
Bug 598881 - Unimplemented GdkWindowImplIface methods crash gimp on OSX
Move screen initialization to gdkscreen-quartz.c
Setup monitor rects during screen initialization and re-use data
Register and handle a display reconfiguration callback
Create a proper subclass of GdkScreen: GdkScreenQuartz
Move screen resolution setup to GdkScreenQuartz initializer
Emit monitors-changed signal when appropriate
Use screen when emitting signal, not _gdk_screen
Update documentation for ::monitors-changed to mention OS X support
Be consistent with X11: emit monitors-changed first, then size-changed
Rework coordinate transformation to be based on root window
Support arbitrary screen layouts
Update size of root window after display reconfiguration
Remove unused variable (fix compiler warning)
Fixup get_nsscreen_for_x()
Update position of toplevels after display reconfiguration
Update copyright
Leonid Kanter (3):
Updated Russian translation
Updated Russian translation
Updated Russian translation
Luca Ferretti (2):
Minor fixes
Add translators comments for tab labels (closes 599118)
Manoj Kumar Giri (1):
Updated Oriya Translation
Marek Kasik (4):
A small correction of previous commit
Show correct print preview
Rotate number-up layout according to orientation when printing
Don't assign a GtkPageOrientation to a boolean value
Matej UrbanÄ?iÄ? (3):
Updated Slovenian translation
Updated Slovenian translation
Updated Slovenian translation
Matthew Barnes (1):
Bug 581150 - GtkIconView tries to paint items with invalid sizes
Matthias Clasen (18):
Bump version
Make selecting the last character work again
Fix doc build
Documentation and stylistic fixups
Add GtkSpinner to the widget gallery
Fix a problem in GtkImage size allocation
Don't omit GTK_ICON_SIZE_DIALOG
Correct a small oversight
Update compose sequences
Fixes for the compose-parse.py script
Fix issues with symbolic colors in rc file parsing
Allow setting type hints on unmapped windows
Updates
Remove en shaw from LINGUAS
Documentation and stylistic fixups
Work around a gtk-doc formatting problem
Another property formatting fix
2.19.0
Michael Emmel (1):
Fix for position bug
Michael Natterer (3):
Revert "Remove deprecated GtkContainer function and macros"
Don't allow to include this new header individually
Add single-include guard and reduce includes to what's needed
Nguy�n Thái Ng�c Duy (1):
po/vi.po: update translation of "Places"
Nick Schermer (1):
gtk_init_with_args() arguments should be const gchar*
Paolo Borelli (1):
Notify the "active" property of the spinner only when needed
Simos Xenitellis (1):
Updated Greek translation
Thomas Thurman (2):
Shavian translation
Shavian translation fix
Timo Jyrinki (1):
Updated Finnish translation by Jiri Grönroos.
Tor Lillqvist (14):
Don't ignore SIGPIPE unless it exists
Fix the GDI+ gdk-pixbuf loader
Don't include gdkwin32.h when testing Objective-C++
Create and install gtk-update-icon-cache.exe.manifest to avoid UAC
Don't use XP themes until they work
Fix build on Windows
Correct function names in debugging output
Remove unused variables and static functions
More meaningful debugging output in gdk_win32_window_get_root_coords
Delete unused leftover static function
Add missing newline to debugging output
Delete a couple of leftover commented-out lines
Use correct size for root window with multiple monitors
Use correct type text/uri-list for the dropped files selection
Xan Lopez (1):
Do not assign the parent class twice
Yevgen Muntyan (2):
Use standard mac shortcuts
Use standard mac shortcuts: add gtk/gtkrc.key.mac
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]