Chronojump on Maemo (Nokia 770 / Nokia 800) status, problems and screenshots!!

We started working on a release of Chronojump for the Maemo platform.,9008,,00.html

"Maemo is an open source development platform for Linux-based handhelds"

The nice thing is: we will use chronojump on a handheld computer, and
in the future, mono-maemo will be working on more devices. It's like a
return to original Ergojump PSION device but with chronopic.

There are two main things to solve:
1.- receiving data from chronopic
2.- chronojump application working on Maemo

1.- receiving data from chronopic

770 has a MiniUSB port, the good thing is that it can be used in
"peripheral mode" (like all pdas, ...) and in host mode. For our needs
we use host mode, But there are two caveats:
1.- it cannot power the attached peripheral (chronopic). This is not a
problem because chronopic gets powered with batteries or a voltage
adapter (alimentador)
2.- the usb chipset needs to be powered itself in some way

when it's working we hope there are no problems to comunicate with chronopic

It seems Nokia 800 has some usb host chips that probably make this
easier (but the kernel is compiled without the option) (and
continue thread...)
(and continue thread...)
(and continue thread...)

2.- chronojump application working on Maemo

There are mono packages for maemo since a month:

chronojump_mini is working at the first time (no gtk, no sqlite)

[see atacched screenshot chronojump_mini_maemo.png]

Chronojump sqlite is not a problem because we copied by hand (from
another Mono on installation on Linux)
[Linux box] $ cp
[Nokia 770] # cp /media/mmc1/Mono.Data.SqliteClient.dll /usr/lib/mono/gac/.
and worked!!

chronojump is compiled with gtk1 (not gtk2) and mono-maemo packages
are for gtk2. Then there are two possible solutions:
2.a.- compile chronojump to gtk2
2.b.- try that mono-maemo works with gtk1

2.a.- compile chronojump to gtk2
1.-The NPlot packages (graphs in stats) not work with gtk2 (probably
someone has worked on this last months), then we have to loose graph
stats commenting:
//w.Add (plot);
on src/stats/main.cs
2.- The comboboxes are deprecated on gtk2, and we should migrate all
to other type of combos
3.- The treeStores are not working ok, this fails: (used lots of times
on chronojump)
string selectedAsString = (string) model.GetValue (iter, 0);
also this:
int selectedAsInt = (int) model.GetValue (iter, 0);
We will write to mono-maemo packages to fix this GetValue problem
4.- a dialog can be "modal" but be hidden by main window (unpossible
to clic on "accept") We will try to use Hildon widgets or change
initial "chronojump simulated" dialog to be topLevel ...

We managed to make work chronojump (except for the important problems
above) and we include this screenshots

[see atacched screenshots chronojump_maemo*.png

Makefile changes this:
CHRONOJUMP_LIB =  -pkg:gtk-sharp -pkg:glade-sharp -r:System.Data
-r:Mono.Data.SqliteClient -r:System.Web.Services

CHRONOJUMP_LIB =  -pkg:gtk-sharp-2.0 -pkg:glade-sharp-2.0
-r:System.Data -r:Mono.Data.SqliteClient -r:System.Web.Services

Probably this doesn't work on Windows with .NET and Novell
gtkinstallerForWin... check this!

2.b.- try that mono-maemo works with gtk1

we copied by hand (from another Mono on installation on Linux)
gtk-sharp, glib-sharp, atk-sharp, gdk-sharp

but it doesn't find glibsharpglue

we tried lots of things with no result:
-copy gnome-sharp, pango-sharp, gtksourceview-sharp
-put [from Linux Box] to [Nokia 770] /usr/lib/.
-install maemo-sharp, libmono-system1.0-cil, libmono-system-data1.0-cil
-write log info with: export MONO_LOG_LEVEL=debug & export MONO_LOG_MASK=dll
-cp to gac
-cp to gac/glib-sharp
-cp to chronojump dir
-put a value on LD_LIBRARY_PATH, tried:
export LD_LIBRARY_PATH=/etc/lib
export LD_LIBRARY_PATH=/etc/lib/
export LD_LIBRARY_PATH=/etc/lib/mono/
export LD_LIBRARY_PATH=/etc/lib/mono/gac
-ldconfig cannot be used because there's no /etc/
-see more debug info with: export MONO_LOG_MASK=

now we are going to try to compile with scratchbox kit...

it seems this library comes with libglib1 package (missing on
mono-maemo packages)

Try to include library on compilation (don't know how to do it now)

We will write to mono-maemo packager to fix this glibsharpglue problem
and gtk1 related packages

check also this (but it seems previous to mono-maemo packages):


Attachment: chronojump_maemo_main_window.png
Description: PNG image

Attachment: chronojump_maemo_about.png
Description: PNG image

Attachment: chronojump_maemo_load_session.png
Description: PNG image

Attachment: chronojump_maemo_new_session.png
Description: PNG image

Attachment: chronojump_maemo_new_person.png
Description: PNG image

Attachment: chronojump_maemo_preferences.png
Description: PNG image

Attachment: chronojump_mini.png
Description: PNG image

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]