Re: PGP popups are b0rken on ssh tunnel usage.

On 2018.09.29 10:37, Albrecht Dreß wrote:
Hi Jack:

Thanks a lot for testing this issue, this is really helpful!

Am 29.09.18 02:09 schrieb(en) Jack via balsa-list:
Now I see a difference between running locally and over X/ssh. Locally, I see a popup in the upper right of the screen with things like "Detected a good signature with insufficient validity/trust." When running over X/ssh I see no such message anywhere.

Ok, looks like the same behaviour as I observed with the VM. However, there are *no* hangs as observed by Mario, right?

No popups, not on the console. I think the "(balsa:3174): GLib-GIO-WARNING **: unable to send notifications through org.freedesktop.Notifications: Timeout was reached" might be a hint to what is missing. I suspect some configuration difference gives me just that warning, but Mario gets some type of disruptive notification.

Afaik, GIO tries to send the notification to the dbus instance /on the machine where Balsa is running/, i.e. in the tunnelled case the remote one. Thus, if DBus is running at all, it has no knowledge about the ssh tunnelled X11 session, so the notification is directed to the completely wrong desktop. I have no idea if DBus can be tunnelled through ssh, too (on my box, it always listens on a local unix socket, which ssh cannot forward). So I agree with you that Mario's issue is probably caused by a (DBus?) configuration issue.

I don't think it will be possible to fix it within Balsa, apart from adding a config item to disable desktop notifications entirely.
Hi Albrecht and Mario,

In my case, launching balsa somehow also includes running dbus-launch, but I guess it can't communicate with any of the running dbus-deamon sessions. Even if it did, it wouldn't make sense to pop up a message on the server (which might well not have X running anyway.) Running dbus-monitor in my kde session, I see no activity from balsa, but running it in the console from which I launched balsa, I do see various messages, and eventually what I think it the timeout error. I wonder if dbus could be configured to launch a daemon if none is found, and popups should get properly redirected through the ssh tunnel. Anyway - that would be a dbus enhancement or configuration, not a balsa thing.

What is still not clear to me is why all I get is a timeout note to the console, but Mario gets a freeze (it's still not clear what a "text popup" is).

Ah! - see the AUTOMATIC LAUNCHING of "man dbus-launch". It seems to imply that dbus-launch might actually launch a new dbus-daemon, but I'm not certain. I do think that info might point in the direction that needs to be followed, but it's going to take me a while to actually understand it all. It's also not clear to me where in the ssh/balsa launch process that the dbus-launch is actually getting called.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]