Re: PGP popups are b0rken on ssh tunnel usage.

On 2018.09.28 11:30, Albrecht Dreß wrote:
Am 28.09.18 14:41 schrieb(en) Mario Mikočević:
- login on pc-A
- start X server
- start ssh from pc-A to pc-B with X11 tunneling
- start balsa on pc-B
- open *ANY* email with PGP signature
        -> balsa window frozen
        -> ssh window gets *text* *popup*

What exactly do do mean with “popup” - a real dialogue, of the desktop notification bubble?

As I don't have two machines, I cannot reproduce this scenario completely. However, I ran a VM, then logged into the host machine via ssh -X, and ran balsa (current git master). The window appears on the VM guest's X11, but the desktop notification bubble /still/ appears on the hosts' X11 screen.

I can only guess that in your case there is no X server running on PC-B, which “somehow” blocks the propagation of the notification. Peter recently migrated notifications to g_application_send_notification(), so my build may actually behave differently than yours, though.

All other popups work as expected (new email, filters, properties, etc ..)

The notification bubble about new messages /also/ appears on the wrong (host, not guest) X11 screen for me. There is nothing special about gpg notifications, btw. – they use that same primitives as *all* other Balsa notifications.

To me this looks as if the desktop notifications are broken when ssh tunneling is involved (but this may be a false positive as I'm using a vm). Anyone out there with more insight (or two boxes for testing)?

Seems to (mostly?) work ok for me. On Artix linux laptop, ssh -Y to my Gentoo desktop and run balsa. Click on the "Check cryptographic signature" button and the message gets a box around it with a lock displayed. At the bottom - "PGP signature is valid" and if I click on that to get the details, on the console I see "** Message: show_public_key_data: xxxxx" (with xxxxx being three hex strings.) If I click "Search key server for updates to this key" I get a popup "Cannot find a key with fingerprint xxxx on the key server" which seems to show the pop-up works correctly, but my gpg config is still not right. I've tried a few times, and had a few crashes (with no dump or error, just silent) but a small number of "(balsa:3174): GLib-GIO-WARNING **: unable to send notifications through org.freedesktop.Notifications: Timeout was reached".
I've seen no popups on the Gentoo box.
If I go to the bottom of a message before clicking the "check" box, and instead, click on "open part with KGpg" byt the detached openPGP signature, on the console, I see

log_kgpg: checking version of GnuPG executable "gpg"
log_kgpg: version is "2.2.8" 131592
QSystemTrayIcon::setVisible: No Icon set

and a KGpg icon appears in the laptop task bar. Clicking on it brings up KGpg, but without any indication it knows which signature I'm looking for.

Bottom line - I really don't know if this all means I'm not seeing the same problem, or if there is some configuration difference, either in ssh, X, balsa, or gpg.

Let me know if there is anything specific I can test.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]