Re: Please help access gmail with IMAP

Thanks for your answer Peter.

In fact, when I checked my mailbox again, I found that Google sent me
a message to inform that they had blocked an attempt to access my
account and if that was really me, there's a configuration switch to
enable access to "less secure applications".

But before I do that, as I don't know to what extent it might weaken
the security of my account, I'll try changing Balsa's settings as you
suggest to see whether that makes it "more secure".


2015-04-06 1:07 GMT+02:00, Peter Bloomfield <peterbloomfield bellsouth net>:
Hello Gerardo!

On 04/05/2015 06:48:32 PM Sun, Gerardo Ballabio wrote:
Hello all,
I tried to configure Balsa to access my gmail account with IMAP, but
failed. Please help.
For the moment I'm only interested in reading email, not sending.

Gmail instructions say I should first activate IMAP in the Gmail
settings. I've done that. Then they say I should set up my email
client as follows:

Incoming mail server (IMAP), SSL required
- port: 993
- requires SSL: yes

So I opened Balsa, clicked Edit/Preferences/Remote mailbox

I figured that Remote IMAP mailbox might not be the right choice and
tried Remote IMAP folder too.

Yes, that's the right choice!

I filled the fields:
- Descriptive name: gmail
- Server:
- User name: gerardo ballabio gmail com
- Password: <my gmail password>
- Anonymous access: not ticked
- Remember password in keyring: ticked
- Subscribed folders only: not ticked
- Always show INBOX: ticked
- Prefix: <blank>
- Advanced/Use SSL: ticked
- Advanced/Use TLS: If Possible (greyed out)
- Advanced/Max number of connections: 20
- Advanced/Enable persistent cache: ticked
- Advanced/Use IDLE command: not ticked
- Advanced/Enable bug workarounds: not ticked
- Advanced/Use STATUS for mailbox checking: not ticked

That's a close match to what I use, except that I have ticked "Enable bug
workarounds" (and "Use STATUS for mailbox checking", but that's probably
irrelevant). GMail is a quirky IMAP server, and you may really need the

This time it seems Balsa doesn't even let me try to open the folder:
when I click on it in the left pane, it doesn't move the focus.

If using the bug workarounds doesn't fix the issue, try running Balsa from
the command line with the "-D" option--you'll see a transcript of the dialog
with the GMail server on the console, and it may give you a hint as to
what's going wrong. Don't post the transcript to the list without *very*
carefully sanitizing it, though.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]