Re: preferred app question

On 2011.10.02 10:22, Peter Bloomfield wrote:
Hi Jack and Ildar,

On Oct  1, 2011, at 10:41 PM, Ildar Mulyukov wrote:
On 02.10.2011 02:51:49, Jack Ostroff (CT D8 TC) wrote:
I just received an email, with an attached wmv file. Looking at the message parts, it shows as Windows Media video, which seems good. However, selecting it only offers "Open part with gmplayer" or "Save part."
Where should I configure this stuff?

This, again, is the MIME staff. And it's configured differently in different distros. Balsa just follows system settings.
Probably asking your distro gurus would yield better results.

Agreed, it is all connected with mime-types. But ISTR cases where the two mechanisms offered inconsistent choices, too. The button that's shown when you select a part offers the app that is suggested by g_app_info_get_default_for_type(); the right-click menu for the "Message parts" tree begins with this app, and adds any other that's suggested by g_app_info_get_all_for_type().

With Nautilus, the default app is set by selecting a file of the relevant type, then 'Properties':'Open with' on the context menu for that file--which I find really obscure, but is apparently acceptable to the UI gurus. The other apps might be found by searching *.desktop files for apps that declare that they can handle the mime-type--I'm not sure. How it's all handled with other file managers is a mystery to me.

I'm replying to this ancient thread because this problem just happened again, and I want to record getting the solution someplace where others might be able to find it.

In my case, I'm running a KDE system on Gentoo, so I only have the absolutely minimally necessary gnome libraries installed. I do not use systemd, so I actually can't use any of the Gnome UI tools, such as Nautilus or Gnome-control-panel (or whatever the name really is.) Everything had been fine, while I was using Firefox as my primary browser, with several others also installed. However, I recently uninstalled firefox, and installed firefox-bin. (For those who don't know, Gentoo is a source based distro, but sometimes it's easier to install a pre-compiled version.) I suppose in order to allow one to have both firefox and firefox-bin installed at the same time, all references to those apps are different, so the -bin is not simply a drop-in replacement.

Symptom - when I right click on an html part in a message part list, firefox-bin was the first app listed. However, clicking on any URL within a message opened it in Opera. Right clicking on the link and selecting copy link worked, but is a nuisance, especially since I generally just clicked first.

Solution - after hunting through many google results, I finally was led to /usr/share/applications/mime.cache. I hunted for every line referring to opera, and moved that reference to after any mention of firefox-bin. Not sure why that worked, and similar edit to ~/.local/share/applications/mime.cache did not, but perhaps that's just a quirk of my setup.

Anyway - I'm not happy again.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]