Re: Balsa can't download a mail with a long line, gets stuck in endless dup-creating loop.

Because web mail is too painful for me, I'll just add a few comments up top.

I have occasionally noticed problems with word wrap, but much of the time, either I'm on webmail, or I'm replying (in balsa) to something sent in webmail.  I think part of the issue is that a series of several lines, all about the same length looks like a paragraph, but isn't really.  There is a hard break between each, instead of being flowed only by the display.  Inserting into one of those lines add's a wrap to that paragraph only, and if that paragraph is only one line, you get what you are complaining about.  I do make frequent use of "reflow" (select the paragraph, perhaps without the last line, and hit CTL-R.

In ubuntu, the deps are just the runtime libraries.  When you build balsa yourself, you need the -devel version so you have the headers available.  For example, if the ubuntu packaged version of balsa needs ssh, then to build balsa, you need ssh-devel (just for the idea, I don't know if that's a real package).  These are not nested dependencies, but development versions of the package so you have the headers balsa needs to compile and link, not just to run.  You do also have the issue of dependencies of dependencies, but other than reading the .configure script, finding a new one each time you do .configure is the standard approach.

Your send problem seems strange.  When I get a send error (usually due to my ISP) I just un-flag and then send queued mail.  If it's still not going, I'd try to figure out why.  Try the command line flag to debug the pop connection.

From: Rob Landley <rob landley net>
To: Jack <ostroffjh sbcglobal net>
Cc: balsa-list gnome org; Pawel Salek <pawsa0 gmail com>
Sent: Wed, October 24, 2012 7:30:00 PM
Subject: Re: Balsa can't download a mail with a long line, gets stuck in endless dup-creating loop.

On 10/24/2012 04:43:08 PM, Jack wrote:
> Sorry for top posting - its' webmail....  Only addressing  a few
> points.

Given that this is a mailing list about a mail client, and that the
topic of the thread is (more or less) whether or not said
mail client meets its

If you cursor up into a paragraph and insert in the middle, the
wordwrap due to insertion sticks the last word on its own line, and
then the word after that one its own line, and so on. How has nobody
previously noticed this?

Anyway, the fact you're using webmail could be relevant. Just sayin'.

> That's about the point at which I lost interest, but it looks like
> I'll have to
> get back to it because balsa is... sort of unfinished?
> --> As a user, not a developer, I've been using Balsa with great luck
> for many
> years.  There are certainly things that could be improved, but that's
> the case
> with anything.

The wordwrapping logic is one of those things that could be improved.
The above is what "reply all" gave me, unmodified.

>  I'd keep going through the dependencies.  I'm on
> Gentoo, so even
> a package install does a full build so all the dependencies are there
> if I want
> to compile from git.  However, in Ubuntu/xubuntu, you could look at
> the package
> in the Synaptic or other package manager and check the listed
> dependencies.  You
> probably need the -devel version of most of them to compile, but that
> should
> cover most of them.

I installed balsa, its dependencies are resolved. The -devel packages
aren't all direct dependencies, they're dependencies of dependencies.
Since the website doesn't seem to bother to list them, the easy way to
find them is to run configure over and over.

(Luckily I found the --without-gnome option to make the process
slightly less painful.)

i wouldn't bother to report any of my pet peeves to the list if I
didn't think it was fixable, and worth fixing. I'm just a bit surprised
at the rough edges.

> When you cut and paste text, the window doesn't scroll. The first
> email I sent
> had a typo in the smtp configuration and "send queued" seems to be a
> complete
> NOP, so there's an email message in my outbox which just won't send.
> --> I've had this problem in the past.  You don't need to toggle
> unread, you
> need to toggle "flagged."  Then a send/receive will actually send it.
> You can
> also edit it (outside of Balsa) in the Outbox.
> [snip...]

It wouldn't send, so I unflagged it. Do I need to re-flag it to get it
to send?

Just tried flagging, unflagging, reflagging, with both a "send queued
mail" and a "send/receive" in between each one. It won't budge.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]