Re: building 2.3.28

On 11/07/2009 07:29:18 PM Sat, Jack wrote:
On 2009.11.07 15:15, MK wrote:
So I would much prefer to build from source, which is what I do with a lot of software (I am a C programmer, I have some gtk projects and my desktop at home is source built from gtk on up, so using packages is sometimes awkward or undesirable). I believe I tried to build balsa once or twice in the past and failed and just left it at that, but I would really, really like it to work out since I cannot find ANY other viable GUI email clients for linux. The latest attempt was:

configure --enable-pcre --disable-static --without-gnome --with-gnu-ld

and it crapped out here:

address-view.c: In function ‘lbav_entry_setup_matches’:
address-view.c:230: error: ‘internet_address_unref’ undeclared (first
use in this function)
address-view.c:230: error: (Each undeclared identifier is reported only
address-view.c:230: error: for each function it appears in.)

I don't really want to debug this myself and was wondering if anyone
had any advice or (egad) had actually gotten 2.3.28 to build!

2.3.28 is not the latest version. I'm using 2.4.1 under Gentoo, so it was compiled on my machine with no problems, although not manually. It might be worth trying a newer version.

Yes--it looks as though you have GMime 2.4, and Balsa 2.3 requires GMime <= 2.2. Try the Balsa 2.4.1 tarball from <URL:>, which does require GMime 2.4.


Attachment: pgpC3Gn9f4Uet.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]