Re: Fails to sign a message after gnupg2/gpgsm upgrade

On Aug 26, 2009, at  2:41 PM, Albrecht Dreß wrote:
Am 26.08.09 20:17 schrieb(en) Peter Bloomfield:
- from the shell, run "gpg --sign" which should pop up the passphrase dialogue (pinentry). If it doesn't, there is a communication problem between gpg and the agent;

OK, no popup, just "You need a passphrase to unlock the secret key for..." on the console.

O.k., then the agent is not able to communicate with pinentry... this is *not* a Balsa issue, but a more fundamental one, which will let any application using gpg (or gpgme) fail.

I tried "gpg --sign" with the downgraded gnupg2 package, which works with Balsa, and got the same console message, still no popup.

You should have a look at your ~/.gnupg/gpg-agent.conf file, and check if it still points to a valid pinentry application - maybe the new pinentry packages shifted the install folder? You could add the '--log-file' and '--debug-all' options to the agent (or gpg-agent.conf) and check the error output.

My ~/.gnupg/gpg-agent.confhasn't had a "pinentry-program" entry for a while; I added one, but still didn't get a popup from gpg. The installation looks the same as always: /usr/bin/pinentry -> /etc/alternatives/pinentry -> /usr/bin/pinentry-gtk -> pinentry-gtk-2.

To check pinentry itself, launch it from the shell and then type 'GETPIN' which should pop up a dialogue and ask for 'PIN:'.

Yes, that works.


Attachment: pgpeRJlkHxxrI.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]