Re: Some hints for usability improvements

În data de Sî, 28 ian 06 la 20:36, Peter Bloomfield a scris:
On 01/19/2006 04:23:03 PM Thu, Mişu Moldovan wrote:
[ snip ]
5) As someone that usually reads only the new mails on several folders and subfolders in an IMAP hierarchy I frequently navigate from one new message to another using the Ctrl-N shortcut. When there are no new messages in the current folder I have to manually switch to a folder with some new mails to continue reading them. Sylpheed does what I mean and asks me if it should change automatically to the next new mail in the next subfolder in my IMAP hierarchy. True also for other MUA's.

Marcin Deranek opened a bug <> on this topic. A patch there implements the general idea, though without any popup to confirm changing mailboxes--I tried it *with* one for about half a minute, and found it too annoying!

Please consider the case of using only the keyboard for reading mail. Here's what happens in current Balsa when there is no new mail left in the current IMAP sub-folder, but there are some unread mails in other IMAP sub-folders: * I press Ctrl-N (not knowing I have just read the last new mail in the current IMAP sub-folder) and no new mail is selected. In fact the current mail remains opened in the preview pane, but the "select" frame moves to the next mail. * I press Shift-Tab twice to move the focus backwards to the IMAP folder list * I manually move to the next IMAP sub-folder with new mail using the cursor keys and pressing Enter after selecting it. * The first new mail is opened in the preview pane only if the sub-folder was not already opened. If the sub-folder was already opened, the last previewed mail is opened and I have to press Ctrl-N again.

I do this on a regular basis, especially at work where I receive mail in about 20 IMAP sub-folders, so I'm pretty familiar with the above (quite awkward) procedure.

Only having to confirm opening the next unread mail in the next IMAP sub-folder with new mail would be a great improvement. However, I haven't tried the patch from Bugzilla as it doesn't apply cleanly on my already patched 2.3.8 tree and I'm somewhat reluctant on trying the CVS version on this machine.



Attachment: pgp41W77urfTK.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]