can balsa run on a RH7.3 + gnome-1.4 + glibc-2.3.2?

I've been using balsa on my RedHat7.3 for a long time. The balsa level is 1.4.2 that came with RedHat. Recently I needed to upgrade the glibc from 2.2.5 to 2.3.2 (for various reasons I don't want to upgrade to RH9). I was expecting (hoping) that application packages such as balsa would not be affected as glibc-2.3.2 is binary-backward-compatible to 2.2.5. And in fact, after installing a new XFree86 which I knew I would have to, everything else did work - except balsa, which failed with a segv. I've tried building a new balsa (1.4.4) from src on the glibc-2.3.2 system, both with and without threads. Each of those also segv'd, althugh in different places. (The one without threads did get as far as bringing up the window and showing the mailboxes but then segv'd). I went as far as to build it (1.4.4) one more time on a restored glibc-2.2.5, building with -static to make a static-lib executable. I couldn't statically-link all shared-obj's altogether but did link all the system libs such as libc.a. That also segv'd when run on glibc-2.3.2, in yet another place.

Maybe what I'm trying to do is impossible - is there in fact some hard dependency in the balsa 1.4.4 on glibc-2.2.5? But I thought I would ask here in case anyone else has ever succeeded with this. Is it worth a shot trying balsa-2.x.x? But I have gnome-1.4.

( I tried to search the mail archives but get "non-existtent URL" error - no mailman/search???.)


Add photos to your e-mail with MSN Premium. Get 2 months FREE*

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]