Re: Balsa crashes when receiving email

On 2002.01.18 02:46 Paulo Andre' wrote:

> I tried to compile balsa 1.3.0 CVS with this but no success. It claims
> I don't have esmtp library installed. This is stupid since it's 
> obvious
> I do have it installed otherwise I couldn't have configured and 
> compile

As always with autoconf-generated configure scripts, check contents of 
config.log file. The configure script basically tries to link a dummy 
object file with libesmtp.(a|so). Assuming that you installed libestmp 
in /usr/local/lib, and libraries in this directory are not taken into 
consideration by your ld, you may want to run
LIBS=-L/usr/local/lib ./configure <options>

We should probably use libesmtp-config to determine the location of the 
libesmtp library.

> before in the first place. I even tried compiling ESMTP with
> --enable-pthreads=on, but it yelds the same result.

No, this won't change a thing, I am afraid.

Apart from this, the error you experience seems strange. I am using 
daily balsa with POP and never saw something like this. I am tempted to 
blame it on library mess (I do not know which distribution do you use 
but it is easy to make one by abusing rpm --nodeps on RPM-based 
systems). Anyway, I look forward to more information from you.

Pawel Salek (
Theoretical Chemistry Division, KTH

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]