compiling problems balsa 1.3.5 on Solaris

Having a problem compiling any version of Balsa above 1.2.4 on my Solaris 

Configure is fine, and the normal switches are set, --disable-flock 
--enable-fcntl --disable-more-warnings etc.
but during the make process itt falls over thus:

gcc -DLIBMUTT -I. -I.. -I../libmutt   -I/opt/gnome/include/gtk-1.2 
-I/opt/gnome/include/glib-1.2 -I/opt/gnome/lib/glib/include 
-I/usr/openwin/include  -g -O2 -I/opt/gnome/include/glib-1.2 
-I/opt/gnome/lib/glib/include -D_REENTRANT -I/opt/gnome/include/glib-1.2 
-I/opt/gnome/lib/glib/include -I/opt/gnome/include/gtk-1.2 
-I/usr/openwin/include -I/opt/gnome/include/gnome-1.0 
-DNEED_GNOMESUPPORT_H -I/opt/gnome/lib/gnome-libs/include 
-I/opt/gnome/include/freetype2 -I/opt/gnome/include/gdk-pixbuf-1.0 
-I/opt/gnome/include/gnome-xml -I/opt/gnome/include/gnome-vfs-1.0 
-I/opt/gnome/lib/gnome-vfs-1.0/include -I/opt/gnome/include 
-I/opt/gnome/include/orbit-1.0 -c pop3.c
In file included from pop3.c:44:
../libmutt/mutt.h:185: parse error before numeric constant
make[2]: *** [pop3.o] Error 1 make[2]: Leaving directory 
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/scott/balsa-1.3.5'
make: *** [all-recursive-am] Error 2

I saw in the NEWS a note that said " (there is a yet-unidentified build 
problem on some boxes)" does this apply to Solaris ?

Any help gratefully welcomed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]