[xslt] Arrow keys not working in xmllint shell interface?


I have two different systems.  One is Ubuntu 14.04, the other is CentOS 7.3.

Both systems are running xmllint using libxml 20901, and the compile time options are the same for both.

On the Ubuntu system, if I run "xmllint --shell somefile.xml", I can use the up-arrow key to see the command history, or use the left/right arrows to move the cursor to various points on the command I'm entering at the prompt.  I'd like to have the same functionality on CentOS.

However, the CentOS-based xmllint doesn't recognize the arrow keys.  The keys dump their ASCII equivalent (e.g. "^[[A" for the up arrow) to the screen rather than displaying the command history or moving the cursor.  This occurs in a remote login (ssh via Putty) and in a terminal window opened on the console.

The "up arrow for history" functionality DOES work on the CentOS box in the bash shell, and in Python.  It's only in xmllint that it's failing.

The $TERM is set to "xterm" on the Ubuntu system.  On Ubuntu, the $TERM is set to "xterm", but setting the $TERM to "xterm" on CentOS has no effect upon xmllint.  I've also tried "vt100" and "vt220"...no change.  The default $TERM for this is xterm-256color.

It occurs regardless of whether I've used SSH to access the system, opened a terminal window in X, or used CTRL-ALT-F2 to use a TTY.

I've installed xmllint using a pre-packaged release using the CentOS admin tools, and I've compiled it from source.  The arrow keys don't work in either case.

Any thoughts on what I need to do to get this functionality on CentOS?

Thanks in advance,

Peter Kukla

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]