[xslt] xinclude memory error with large docs and libxml 2.5.5

Hi folks,

just installed newest libxslt 10028 and libxml 20505

xsltproc -V
"Using libxml 20505, libxslt 10028 and libexslt 719
xsltproc was compiled against libxml 20505, libxslt 10028 and 
libexslt 719
libxslt 10028 was compiled against libxml 20505
libexslt 719 was compiled against libxml 20505"

Everything worked fine until i tried a quite large document with lots 
of XInclude tags which just didnt work.

XInclude did work with other documents

xmllint --xinclude largedoc.xml
gave me
what means "Memory access error" or something similar (segmentation 

I searched archives and bug list but didnt found anything? 
My document is valid as it works with 

/usr/local/bin/xmllint --timing --xinclude mydoc.xml > test.xml
Parsing took 1 ms
Xinclude processing took 3559 ms
Freeing took 188 ms

ls -al test.xml
3.201.087 Mär 27 15:20 test.xml
so 3 mbytes shouldnt be so much???

did i miss any bug report on --xinclude processing with libxml 2.5.5??

any help is greatly appreciated, because i have to get things to work 

kind regards,

Planwerk 6 /websolutions
Herzogstraße 86
40215 Düsseldorf

fon 0211-6015919
fax 0211-6015917

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]