[xslt] libxslt-1.0.10 make fails on HP-UX

Title: libxslt-1.0.10 make fails on HP-UX

I have been struggling for days trying to build  xslt on HP.

It built almost right out of the box for QNX which really surprised me, I did some
experiments with the QNX version of xsltproc and the results were as expected.

But when I tried to build it on HP, nothing will compile.

I have discovered that the following HP cc options are missing, and when
added by hand, things will compile.

        -Aa -D_HPUX_SOURCE    and   -Wp, -H30000

When I compared the configure script between  libxml2-2.4.13 and libxslt-1.0.10
I notice that there is a section in libxml2-2.4.13 that deals with HP-UX.
The similarity of the two configure scripts is striking.  At about line 1418, there
are approximately 110 lines of code in libxml2 that do not appear in xslt version.
My feeling is that if these were included that xslt would build on HP.

So my questions are:   Have I done something stupid ?
                                 Is libxslt-1.0.10  set up to build on HP ?
                                 What do I need to do to get this libxslt to build on HP ?

I have tried two different HP systems, and the results are the same on both.
I tried changing the order of the targets: breakpoint and libxslt to see if the compile
errors were a function of the file being compiled.  The errors were identical.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]