Re: [xml] Strange validation errors in libxml 2.9.0 with MSVC 2010

On Sat, Apr 06, 2013 at 07:50:56PM -0400, Zoltán Ördögh (GMail) wrote:
I saw this code in xmllint.c (removed conditionals that do not apply):
I tried using the exact same code but I still get the same validation
errors on the first call to xmlTextReaderRead...
It is vexing me...
Any thoughts?

  See your xml and the system identifier you use for the DTD


if I use that I get an error that the DTD fails to be loaded on linux
and validation fails (xml and dtd being in the same directory) switching

works after that i.e. xmllint code succeeds

file:// URIs are (or used to be) completely underspecified, and
what you use there would mean on a Linux machine, the file testme.dtd
which is in the . directory under to root of the filesystem of the
localhost machine, i.e. /testme.dtd instead of ./testme.dtd
What is does on Windows and why, I can't guess and I can't test,
simply run your program under a debugger, since you have a reliable
behaviour !


Daniel Veillard      | Open Source and Standards, Red Hat
veillard redhat com  | libxml Gnome XML XSLT toolkit | virtualization library

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]