Re: [xml] question on versions

On 2012-03-15, at 17:48, Joshua Alexander <egomagickian gmail com> wrote:

Hi folks,

I recently built libxml2 2.7.8 on OS X and now apache won't start saying " requires version 
10.0.0 or later, but libxml2.2.dylib provides version 9.0.0"

That doesn't make sense to me, so I'm curious, is what apache's saying accurate... or what "version" is 
libxml2 2.7.8 supposed to provide? 

I would expect libxml2 v2.7.8 to result in libxml2.2.dylib having a "compatibility version" of 10.0.0 and a 
"current version" of 10.8.0. A version in the 9.x.y range is indicative of libxml2 v2.6.x. What the error is 
saying is that the version of that is being loaded was compiled against libxml2 v2.7.x but the 
version of libxml2.2.dylib that is being found at runtime is from libxml2 v2.6.x. If you are on an older 
version of OS X (e.g., pre-10.6) then the error suggests that the system version of libxml2.2.dylib is being 
loaded rather than your locally built copy.  If you're on OS X 10.6 or newer then it's hard to guess where 
the old copy of libxml2.2.dylib is coming from.

Hope this helps,

- Mark

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]