Re: [xml] libxml2 crash

Here is a better call stack of the crash:


#0  0x008a1ba3 in strncmp () from /lib/tls/

#1  0x004a32fc in __xmlParserInputBufferCreateFilename (

    URI=0x99f5398 "file:///etc/xml/catalog", enc=XML_CHAR_ENCODING_NONE)

    at xmlIO.c:2528

#2  0x004a3395 in xmlParserInputBufferCreateFilename__internal_alias (

    URI=0x99f5398 "file:///etc/xml/catalog", enc=XML_CHAR_ENCODING_NONE)

    at xmlIO.c:2563

#3  0x004fa310 in xmlParseCatalogFile__internal_alias (

    filename=0x99f5398 "file:///etc/xml/catalog") at catalog.c:901

#4  0x004fb16e in xmlParseXMLCatalogFile (prefer=XML_CATA_PREFER_PUBLIC,

    filename=0x99f5398 "file:///etc/xml/catalog") at catalog.c:1344

#5  0x004fb571 in xmlFetchXMLCatalogFile (catal=0x99f52a8) at catalog.c:1449

#6  0x004fc927 in xmlCatalogListXMLResolve (catal=0x99f52a8, pubID=0x0,

    sysID=0x99f5278 "missing.xml") at catalog.c:2057

#7  0x004fe177 in xmlACatalogResolve__internal_alias (catal=0x99f5330,

    pubID=0x0, sysID=0x99f5278 "missing.xml") at catalog.c:2871

#8  0x004feb46 in xmlCatalogResolve__internal_alias (pubID=0x0,

    sysID=0x99f5278 "missing.xml") at catalog.c:3351

#9  0x004a500b in xmlResolveResourceFromCatalog (URL="" "missing.xml",

    ID=0x0, ctxt=0x99f4568) at xmlIO.c:3808

#10 0x004a516f in xmlDefaultExternalEntityLoader (URL="" "missing.xml",

    ID=0x0, ctxt=0x99f4568) at xmlIO.c:3873

#11 0x004a5297 in xmlLoadExternalEntity__internal_alias (

    URL="" "missing.xml", ID=0x0, ctxt=0x99f4568) at xmlIO.c:3941

#12 0x004c43fb in htmlCtxtReadFile__internal_alias (ctxt=0x99f4568,

    filename=0x80bc7ec "missing.xml", encoding=0x80bc7c0 "foo", options=0)

    at HTMLparser.c:6809

#13 0x0805f454 in test_htmlCtxtReadFile () at testapi.c:1676

#14 0x080617de in test_HTMLparser () at testapi.c:2791

#15 0x0805e656 in testlibxml2 () at testapi.c:1253

#16 0x0805d0de in main (argc=1, argv=0xfef66ef4


Thomas Floodeen, Jr.

Mentor Graphics BSD



From: Floodeenjr, Thomas
Sent: Friday, March 18, 2011 10:47 AM
To: 'xml gnome org'
Subject: RE: libxml2 crash


I confirmed that get this crash running the ./libs/testapi test, and not just in my application.


libxml2-2.7.8 Red Hat 4u6 with gcc 4.1.2.




Thomas Floodeen, Jr.

Mentor Graphics BSD



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]