Re: [xml] Trying to make libxml2 for arm (TI DaVinci)

Then try ./configure ... --host=arm-none-linux-gnueabi
I expect in /opt/arm-2009q1/bin you to find a number of executables
prefixed by arm-none-linux-gnueabi- , as exemple
arm-none-linux-gnueabi-gcc . So before to run configure set PATH
export PATH


"./configure --host=arm-none-linux-gnueabi" seems to work (I had no value
I wanted in your elipses marks).  "make" worked after that.  However,
"sudo make install" died with the following:

libtool: install: arm-none-linux-gnueabi-ranlib /usr/local/lib/libxml2.a
./libtool: line 1119: arm-none-linux-gnueabi-ranlib: command not found
make[2]: *** [install-libLTLIBRARIES] Error 127
make[2]: Leaving directory
make[1]: *** [install-am] Error 2
make[1]: Leaving directory
make: *** [install-recursive] Error 1

I look and find /opt/arm-2009q1/bin/arm-none-linux-gnueabi-ranlib indeed
exists and offers help when I run it by hand with no arguments.  Also, I
confirmed /opt/arm-2009q1/bin is still in the path.

What should I try next to get the "make install" to work?  I can't fathom
why arm-none-linux-gnueabi-ranlib command is not found.  Is it saying
...ranlib is missing, or the command given to ...ranlib?  Note that
/usr/local/lib/libxml2.a does exist.

Thanks VERY much for your continued assistance.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]