Re: [xml] Cannot compile with dlfcn (Win32)

On Thu, Jan 17, 2008 at 11:52:21AM +0200, carlo.bramix wrote:
I downloaded the current SVN version of LibXML-2 and I tried to compile it under Mingw32.
During compilation I discovered a bug that blocked the process.
The fact happens only if you install dlfcn package into the Mingw32 enviroment.
Into xmlmodule.c there is a conflict with two different implementations, so I fixed it by excluding the 
dlfcn support if the _WIN32 is detected.
After applying the fix, everything worked fine.
I hope it could be possible to commit this very simple fix, without the need of subscribing to bugzilla.
Keep up the good work.

  Okay, this makes sense as _WIN32 has its own implementation later in the

  Applied and commited to SVN,

    thanks !


Red Hat Virtualization group
Daniel Veillard      | virtualization library
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]