Re: [xml] 2.6.22 xmlIO test hanging on AIX

On Wed, Oct 26, 2005 at 07:02:54PM -0500, Albert Chin wrote:
Something odd is occurring for the xmlIO test on AIX 4.3.3, 5.1, 5.2,
and 5.3 with the IBM C compiler. When I run the test suite:
  $ ./testapi xmlIO
it hangs during test_xmlOutputBufferCreateFd(). I started tracing to
determine where it was hanging:
  (testapi.c -- test_xmlIO())
  test_ret += test_xmlOutputBufferCreateFd();

  (testapi.c -- test_xmlOutputBufferCreateFd())

  (testapi.c -- desret_xmlOutputBufferPtr())

  (xmlIO.c - xmlOutputBufferClose())
  if (out->writecallback != NULL)

  (xmlIO.c - xmlOutputBufferFlush())
  ret = out->writecallback(out->context,
             (const char *)out->buffer->content, out->buffer->use);

Once I run the xmlIO test manually, the terminal window hangs after
the above command and the process exits. I don't see this behavior on
Solaris, Tru64 UNIX, IRIX, HP-UX, or Redhat Linux.

Any ideas?

  What fd number was used to build the buffer ?
For some reason it interract with something peculiar that AIX is doing :-)


Daniel Veillard      | Red Hat
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]