Re: [xml] Problem running testapi for libxml2

On Wed, Jan 12, 2005 at 04:42:39PM -0500, ABeylin axsone com wrote:
Hello Daniel, thank you for the quick reply.

On Sun, with the snapshot's source "testapi" still creates core, stack
is attached below.

  I don't understand where, seems in snprintf but the output is unreadable
can you make sure you're compiling with debugging options or someone provides
a patch for Solaris.

On HP, compilation fails with snapshot's source code, failure is
attached below.

  Seems HAVE_SHLLOAD is defined, it was found but the associated #include
is missing (which one ?) so functions and macros are undefined.

On AIX, the tests worked successfully, but for fun I attached the stack
trace from the version 2.6.16

  Okay, that problem is solved.

We are currently trying to port to libxml.
We are building commercial software, and need to use a stable release of

  2.6.16 sounds fairly stable.

Our preference is to build libxml ourselves, instead of downloading
pre-built binaries. 
How do I build a stable version on HP-UX/Sun and AIX platforms?  It has
to be a versioned version (not snapshot).  Are any compilers or versions
of compilers recommended?

  We don't do compiler recommendation. Sun ships libxml2 with Solaris.
In general using a more recent version get the associated bug fixes.


Daniel Veillard      | Red Hat Desktop team
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]