RE: [xml] problem building libxml2 rpm: missing macros.python file

I think Daniel may be saying that it is the package manager itself (RPM)
that is at fault. Have you tried installing libxml2 on each of the Red
Hat machines you have?  If it works on some but not all, it might
support this hypothesis.

Caveat: being a Gentoo guy when I'm not on Windows, I'm about as far
from an expert on RPM as it's possible to be.

-----Original Message-----
From: xml-admin gnome org [mailto:xml-admin gnome org] On 
Behalf Of Sood, Sanjeev
Sent: Friday, April 30, 2004 1:43 PM
To: veillard redhat com
Cc: xml gnome org
Subject: RE: [xml] problem building libxml2 rpm: missing 
macros.python file


Thanks again for your time. I understand the problem little better.

If this is a possible issue with my installation, what could 
I be doing
wrong? I have 4 systems here with 4 different RedHat versions 
(from 7.1,
8.0. 9.0), but none of them seem to have this file. Do I need 
to run any
other rpm command to generate this file? I am fairly new to 
using Linux
and it could easily be a user error on my part. I will appreciate any
tips you can give me on this. Do you see this file on your 
systems where
possibly you have installed libxml or any other rpms? If so, 
can I get a
copy of this file?

Thanks again, and Best regards,

-----Original Message-----
From: Daniel Veillard [mailto:veillard redhat com] 
Sent: Friday, April 30, 2004 10:33 AM
To: Sood, Sanjeev
Cc: xml gnome org
Subject: Re: [xml] problem building libxml2 rpm: missing macros.python

On Fri, Apr 30, 2004 at 10:24:42AM -0700, Sood, Sanjeev wrote:
I appreciate you taking time in responding to my question. I didn't
follow your answer correctly. You say that it seems to be a problem
my rpm installation. Are you referring to the python rpm? I 
also have
system with Redhat 9.0 and even that has the same python rpm, and
macros.python file doesn't seem to be around. 

  The file you are missing will *not* come from a problem with 
the python or python-rpm package. It is *rpm* which is asking for
this, you will have to check your installation, this is in no way
related to libxml2 as far as I can tell (and I worked with those
tools for years).


Daniel Veillard      | Red Hat Desktop team
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine
xml mailing list, project page
xml gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]