Re: [xml] Access Violation in xmlMutexUnlock

On Fri, Sep 05, 2003 at 10:56:56AM +0200, Oliver Stöneberg wrote:
A few times I got an access violation in xmlMutexUnlock, when 
ReleaseMutex tried to release the tok->mutex, which was 0x0000000 in 
the case it tried to free it. Unfortunately I *can't* reproduce this, 
but it happened quite often to me by now :(

I am using libxml2 2.5.10 in a DLL build with Visual Studio 6.0. The 
libxml2 is linked static, uses iconv and native threads.
The portion of code I am using the libxml2 in, is just reading a 
string from memory, then goes to a specific node and atrribute, reads 
the value and closes it again. Everything is closed and free'd 
properly, because it's quite a small amount of code. It happened, 
when 3 threads accssed the DLL. All the other code *is* thread-safe 
(tested and verfied by some test-programs)

Did anyone else ever had this problem? Could it be a problem in the 
I am heavily trying to get a reproducable situation, but it's not 
looking good so far.

  Make sure you start by calling xmlInitParser()
and that you call xmlCleanupParser() only once at the end of the program.
Then try with the CVS version,


Daniel Veillard      | Red Hat Network
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]