RE: [xml] Installation question

Hi Daniel,

Thanks for the quick response.  I tried your suggestion and hit another snag.
One step forward, two steps back...

[root slapshot downloads]# rpm -U libxml2-2.5.8-1.i386.rpm
warning: libxml2-2.5.8-1.i386.rpm: V3 DSA signature: NOKEY, key ID de95bc1f
error: Failed dependencies:
        libxml2 = 2.5.4 is needed by (installed) libxml2-python-2.5.4-1

[root slapshot downloads]# rpm -q libxml2-2.5.4

[root slapshot downloads]# rpm -q libxml2-python-2.5.4-1

I tried to remedy this with

rpm -i --force libxml2-2.5.4-1.i386.rpm libxml2-devel-2.5.4-1.i386.rpm
rpm -U libxml2-2.5.8-1.i386.rpm libxml2-devel-2.5.8-1.i386.rpm

But I still get the same complain about failed dependencies.  Any suggestions?
Also, should I install lib{xml2,xslt}-python also?


-----Original Message-----
From: Daniel Veillard [mailto:veillard redhat com]
Sent: Tuesday, July 15, 2003 7:08 AM
To: Jeff Chen
Cc: xml gnome org
Subject: Re: [xml] Installation question

On Tue, Jul 15, 2003 at 06:58:24AM -0400, Jeff Chen wrote:
2. Now comes the errors when I try to install the RPMs

[root comet i386]# rpm -i libxml2-devel-2.5.8-1.i386.rpm
error: Failed dependencies:
        libxml2 = 2.5.8 is needed by libxml2-devel-2.5.8-1

  You must upgrade libxml2 and libxml2-devel on the same rpm command.
Not specific to libxml2 this is true for nearly any -devel package on
an RPM based system (libxslt too)
  rpm -U libxml2-2.5.8-1.i386.rpm libxml2-devel-2.5.8-1.i386.rpm


Daniel Veillard      | Red Hat Network
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]