Re: [xml] Errors configuring to include "--with-dom"

On Mon, Mar 11, 2002 at 11:25:48AM -0500, Ilya Shindyapin wrote:

This is the error i get when I run:
./configure \
--with-dom \
--with-xml \
--with-zlib \

  This is not libxml2 configure.

So I downloaded libxml2-2.4.17 (I also tried 2.2.7, 2.4.10, and 2.4.16)
I run ./configure  in the appropriate directory (libxml2- works 
-lc -install_name  /usr/local/lib/libxml2.2.dylib -compatibility_version 7 
-current_version 7.17
ld: -undefined error must be used when -twolevel_namespace is in effect
/usr/bin/libtool: internal link edit command failed

   libtool is failing on your platform. Report the bug to the libtool
authors or if as I guessed you're running MacOS X, report the bug to Apple,
so they fix either libtool or their compiler or both. I don't see how to
fix that in libxml2 itself.


Daniel Veillard      | Red Hat Network
veillard redhat com  | libxml Gnome XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]