[xml] New battle in Porting LibXML & LibXSLT to DJGPP: file read error


It appears that something has changed for the worse (when tring to build on
DJGPP on MSDOS) with the latest sources (I downloaded the CVS release two
days ago). The package built fine, but none of the programs run anymore (xmllint,
xsltproc, etc)

They all return the same error:
warning: failed to load external entity "file:///D:/D/xml/test.xml"

... or similar.

I have tried a few tricks in the sources but nothing works. Seems that filenames
are now converted to URL before reading. If it is then trying to do the actual URL
loading via the local socket library, it will cause big problems on DJGPP. It looks like
possible code rewrite??

The latest *working* LibXML on DJGPP I have is 20422. There might have been still
many more since then, but I know that the newest CVS release has this new error.


BA flight sale now at www.lycos.co.uk
New York, £129 rtn. including tax, Friday, 2pm

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]