Re: [xml] make libxml2 for arm

I have tried to compile the libxml2 for arm.
I have installed the tool-chain(skiff).
after unpack the libxml2 source, I do as following~~
export CC=/skiff/local/bin/arm-linux-gcc
export HOST_CC=/skiff/local/bin/arm-linux-gcc
checking host system type... ./config.guess: ./dummy-28066: cannot execute binary file

configure.guess couldnt determine the architecture by using the uname
run this shell script to see what it found.

UNAME_MACHINE=`(uname -m) 2>/dev/null` || UNAME_MACHINE=unknown
UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown  

./config.guess: ./dummy-28066: cannot execute binary file

It then tried some other methods to identify the system by compiling
simple programs and running them. It failed to do this because your
shell cannot execute the temporary test program (dummy-28066) it created
in the current directory. Check your umask - maybe it is not allowing
the execute permissions to be set. It probably doesnt matter though as
these tests arent for arm-linux architectures.

configure: error: can not guess host type; you must specify one

try running configure by forcing the host type :

./configure host=armlinux  

try elf32arm and armelf_linux also.

If your cross-compiling you may need to force other settings too. run
"./configure --help" to see your options.

Peter Farmer            |  Custom XML software   | Internet Engineering 
Zveno Pty Ltd           | Website XML Solutions  | Training & Seminars   |   Open Source Tools    |   - XML XSL Tcl
Peter Farmer zveno com  +------------------------+---------------------
Ph. +61 8 92434146      | Mobile +61 417 906 851 | Fax +61 2 6242 4099

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]