[Vala] new signal syntax

I, for one, would like to express my preference for the old signal syntax (+= and -=) over the new syntax (connect and disconnect). I prefer the old syntax because

1) I find it more readable, especially when a lambda expression is involved.

2) Signals are special: they are part of the language and so I prefer them to be expressed using language syntax rather than what looks like a method call (and which is, I'll grant, likely just a method call behind the scenes). I'm often interested in scanning through code visually to find which signal handlers are set; this is much easier with the += syntax.

In the bug regarding this change (http://bugzilla.gnome.org/show_bug.cgi?id=566847) it was stated that += doesn't seem appropriate for a signal, but I don't think it's really any stranger than, say, using + to concatenate strings even though the operator was originally conceived for numeric addition.

In almost every other way I'm very happy with Vala and the direction of its development. Keep up the great work!


Adam Dingle

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]