Re: [Tracker] RDF Queries

Ah ha! That location happens to not be in my path, which is quite unusual, so I now got it working (well, to start anyway).

Now I got everything to install except for the tracker-applet. Everything else seems to work as of now though, which is progress. I will play with the rdf queries some more when I have more time, but if anybody has advice about making tracker-applet install, that would be great.


Martyn Russell wrote:
Michael Lissner wrote:
I put some time into installing this from source today (~2hrs) and didn't end up much closer. Now I have no tracker at all.

From your distribution, it would probably have been easier to just download the tarball and install it manually. That would have possibly been less work.

My process was to remove the Ubuntu tracker version (sudo aptitude purge tracker), and to install the one from source. I had to install a TON of dependencies to get it to work:

sudo aptitude install libgmime-2.0-2a libgmime-2.0-2-dev dbus-glib-1-dev libdbus-glib-1-dev libhal-dev libhal-storage-dev sqlite3-dev libsqlite3-dev libexif-dev libgsf-1-dev libjpeg62-dev libtiff4-dev libxine-dev libpoppler-dev libgstreamer0.10-dev libpoppler-glib-dev libtotem-plparser-dev libunac1-dev libexempi-dev

This is mostly for metadata extraction.

After all that, I was able to install it, but now when I run trackerd, it says I don't have trackerd installed. I do seem to have the new tracker-info installed, so that's good. And the install went fine, which is good.

The trackerd process is now spawned from DBus. It does exist, just not in the patch. It should be in /usr/lib/tracker/trackerd OR /usr/libexec/trackerd (depending on your distro).

I also couldn't sort out how to install the deskbar applet or the gtk search query window, so those are now gone from my system. I didn't see anything in the documentation about these either.

The tracker-search-tool should definitely be installed. The deskbar applet needs some extra parameters when being built (the configure summary should tell you what is built and what is not).

You should be able to either run tracker-search-tool from the console OR run tracker-applet to start it from the notification area.

Thanks again for the help, hopefully I'll be able to contribute a bit here eventually...I also tried to find people on IRC...but to no avail.

Yea, sorry about that. You should have better luck Monday morning ;)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]